Php files saved , not executed


#1

Hi,
I have installed Owncloud Version 9.1.6 on a new Debian 8 Server, as far as I can judge it seems that the installation went ok. At least the part which was done in the terminal.
occ reported for status :
- installed: true
- version: 9.1.6.2
- versionstring: 9.1.6
- edition:

But when I want to continue with the web installer nothing happens except that I'm asked if I want to open or save that file. (application/x-httpd-php type (3.0 KB) )
Now I'm a bit clueless on what to do next or where to check further.
On the same server wordpress and others are running just fine

Tks
Henning


#2

Sounds like you need to install PHP (mod_php)


#3

Hi,
it is not as it said in the Plesk doc
Quote
mod_php Apache handler is disabled by default in fresh Plesk 12.5 installations.
Resolution

Note: it is not recommended to enable mod_php Apache handler as it is outdated and insecure. Please use PHP in FastCGI or FPM mode instead.
Unquote
I tried with FastCGI settings as well as FPM mode. No success

Tks
Henning


#4

https://doc.owncloud.com/server/10.0/admin_manual/installation/system_requirements.html

There is no valid reason for this statement by Plesk, otherwise Linux Distributions would for sure not ship it.
If you want to use other PHP modules there are configuration recommendations above in the documentation.


#5

Probably also the best to contact a Plesk support forums about this issue.


#6

Hi,
I followed the instruction on how to activate mod_php and now it's working

Tks
Henning