Php version is incorrect but I have php7.3.9


I have trouble with my Php version. Owncloud tells me that I’m running an old version but I’m not.

When I check with php -v I get this :
PHP 7.3.9-1+0~20190902.44+debian9~1.gbpf8534c (cli) (built: Sep 2 2019 13:31:30) ( NTS ) Copyright (c) 1997-2018 The PHP Group Zend Engine v3.3.9, Copyright (c) 1998-2018 Zend Technologies with Zend OPcache v7.3.9-1+0~20190902.44+debian9~1.gbpf8534c, Copyright (c) 1999-2018, by Zend Technologies

but when I connect to my url Owncloud gives me this message :
This version of ownCloud requires at least PHP 7.0.7 You are currently running PHP 5.6.40-12+0~20190902.20+debian9~1.gbpc72558. Please update your PHP version.

Thank you for any help

Hi Julio,

Have a look in /etc/apache2/mods-enabled/. Make sure you enable the correct PHP version in apache, available versions should be visible in /etc/apache2/mods-available/. To enable the corrrect version use the a2enmod command.
Afterwards restart your apache with systemctl restart apache2.
Please be aware that ownCloud only supports PHP 7.3 with the upcoming version 10.3.



Thank you!

I tried what you said, it was php5.6 that was enabled but when I enable 7.3.9, owncloud still tells me that it is not good

Does it only work with 7.3.0?

Please use PHP7.2 until you install ownCloud version 10.3

1 Like

Ok I’ll try that

I will come here again if I have trouble

Thanks again!

you must disable the php7.0 modul:

`sudo a2dismod` then type php7.0