Php5-fpm error sock-file missing

help

#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce
1.
2.
3.

Expected behaviour
When requesting the website of owncloud, cloud.home.hub I expected to see the webpage of my owncloud server.

Actual behaviour
I get a page that tells me that it needs time to process, and I should contact my admin.
In the logs I get this line:

2016/12/30 18:47:29 [crit] 617#617: *1 connect() to unix:/var/run/php5-fpm.sock failed (2: No such file or directory) while connecting to upstream, client: 10.0.1.116, server: cloud.home.hub, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "cloud.home.hub"
/var/run/php5-fpm.sock exists on my oc-server.

Server configuration
Operating system: Debian
Web server: nginx/1.9.10
Database:(PostgreSQL) 9.4.9
PHP version:PHP 5.6.29-0+deb8u1 (cli)
ownCloud version (see ownCloud admin page):9.1.3
Updated from an older ownCloud or fresh install: made an update from an older version to the version mentioned above.
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):I use a second harddirve to store my uploaded files to.

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

#2

Did you start php-fpm?
service php-fpm restart


#3

Sorry that I didn't mention that, it can't start. When trying to execute that command you mentioned, you get: Failed to start php-fpm.service: Unit php-fpm.service failed to load: No such file or directory.


#4

You can check in /etc/init.d/ how the file is called, can also be php5-fpm ... But you did install and configure php-fpm?


#5

I didn't pay attention if it was installed during the installation of oc, so I assume that it was a requirement of oc. In /etc/init.d/ there is php5-fpm.


#6

There are different ways to use php on different webservers. And each distribution names the packages a bit differently, so the command is service php5-fpm restart. If it still doesn't work, check your logfiles for errors during the startup of php5-fpm and verify that the socket path in the php-configuration and nginx-configuration are the same.


#7

In the file /etc/php5/fpm/pool.d/www.conf, there is a line that goes like this listen = /var/run/php5-fpm.sock checking the path confirms me the existence of the sock-file.
This is my www.conf = http://pastebin.com/xGZNbGM0 ; and service php5-fpm status yields:

● php5-fpm.service - The PHP FastCGI Process Manager
Loaded: loaded (/lib/systemd/system/php5-fpm.service; enabled)
Active: active (running) since Sun 2017-01-01 18:07:26 CET; 25min ago
Process: 546 ExecStartPre=/usr/lib/php5/php5-fpm-checkconf (code=exited, status=0/SUCCESS)
Main PID: 1223 (php5-fpm)
Status: "Processes active: 0, idle: 3, Requests: 81, slow: 0, Traffic: 0.1req/sec"
CGroup: /system.slice/php5-fpm.service
├─1223 php-fpm: master process (/etc/php5/fpm/php-fpm.conf)
├─1226 php-fpm: pool www
├─1227 php-fpm: pool www
└─1550 php-fpm: pool www
Jan 01 18:07:26 gitlab php5-fpm[1223]: Cannot adopt OID in NET-SNMP-AGENT-MIB: nsNotifyShutdown ::= { netSnmpNotifications 2 }
Jan 01 18:07:26 gitlab php5-fpm[1223]: Cannot adopt OID in NET-SNMP-AGENT-MIB: nsNotifyRestart ::= { netSnmpNotifications 3 }
Jan 01 18:07:26 gitlab php5-fpm[1223]: Cannot adopt OID in UCD-SNMP-MIB: laErrMessage ::= { laEntry 101 }
Jan 01 18:07:26 gitlab php5-fpm[1223]: Cannot adopt OID in UCD-SNMP-MIB: laErrorFlag ::= { laEntry 100 }
Jan 01 18:07:26 gitlab php5-fpm[1223]: Cannot adopt OID in UCD-SNMP-MIB: laLoadFloat ::= { laEntry 6 }
Jan 01 18:07:26 gitlab php5-fpm[1223]: Cannot adopt OID in UCD-SNMP-MIB: laLoadInt ::= { laEntry 5 }
Jan 01 18:07:26 gitlab php5-fpm[1223]: Cannot adopt OID in UCD-SNMP-MIB: laConfig ::= { laEntry 4 }
Jan 01 18:07:26 gitlab php5-fpm[1223]: Cannot adopt OID in UCD-SNMP-MIB: laLoad ::= { laEntry 3 }
Jan 01 18:07:26 gitlab php5-fpm[1223]: Cannot adopt OID in UCD-SNMP-MIB: laNames ::= { laEntry 2 }
Jan 01 18:07:26 gitlab php5-fpm[1223]: Cannot adopt OID in UCD-SNMP-MIB: laIndex ::= { laEntry 1 }

And the log of php5-fpm:

[01-Jan-2017 17:59:15] NOTICE: fpm is running, pid 1318
[01-Jan-2017 17:59:15] NOTICE: ready to handle connections
[01-Jan-2017 17:59:15] NOTICE: systemd monitor interval set to 10000ms
[01-Jan-2017 18:06:25] NOTICE: Terminating ...
[01-Jan-2017 18:06:25] NOTICE: exiting, bye-bye!
[01-Jan-2017 18:07:22] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful

[01-Jan-2017 18:07:26] NOTICE: fpm is running, pid 1223
[01-Jan-2017 18:07:26] NOTICE: ready to handle connections
[01-Jan-2017 18:07:26] NOTICE: systemd monitor interval set to 10000ms


#8

Have you installed php-snmp? Remove it if you don't need it (http://php.net/manual/en/intro.snmp.php).

The rest of the configuration doesn't look bad, it's probably close to the default one. If removing the snmp-stuff doesn't help, you can also turn on the logging.


#9

Sorry for being absent.
I'm not aware of installing something called 'php-snmp'. Doing an apt-cache search php5-snmp revealed me the package. After uninstalling that package, I restarted the system which didn't change anything.
Since I'm a new user I cannot upload any files, I would have uploaded the nginx.conf file for owncloud.


#10

Just get in touch with a community dedicated for your distro about this. This is not an issue of ownCloud and you can get far better support with distro specific stuff if you ask people knowing that distro.