Please help - lost access to owncloud only within local network

Hello, I’m desperate.
I don’t know how but I’ve lost access to my owncloud ONLY from local network, after trying to renew my certficate with certbot. The remote access via ssl, with certbot created certificate works perfectly (tested by navigating to the page from my phone cell service). But when I access the site from within my local network it says the site can’t be reached and it says the connection is not secure, as if it couldn’t read the certificate (which works perfectly from outside!).

Server configuration

Operating system: Debian 10 - Raspberry Pi 4

Web server: Apache2

Database: mysql

PHP version: 7.4

ownCloud version: (see ownCloud admin page) 10.9.1.2

Updated from an older ownCloud or fresh install: fresh install

Where did you install ownCloud from: followed manual installation guide

Signing status (ownCloud 9.0 and above): ?

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

--> "No errors have been found"

Log in to the web-UI with an administrator account and click on
‘admin’ → ‘Generate Config Report’ → ‘Download ownCloud config report’

Browser log (Chrome) shows this: “crbug/1173575, non-JS module files deprecated.
(anonymous) @ VM10:6789”

→ I would like to attach the config report but it says that I can’t because I am a new user.
→ What I have already tried: deleting all certificates and certbot, reinstalling certbot and making a new certificate. Nothing changed: the cert works perfectly from outside, but the site is still not reachable from local network.

Any help in figuring out what might prevent local access, when remote access works perfectly would be very welcome, thank you in advance!