Post-Install Connection Issues 9.1.5


#1

After a fresh install of OwnCloud on an Ubuntu 16.04 server I have following this guide (with the exception of the IDENTIFIED BY token) I can't connect from any machine but the localhost in which it's installed. I ran into a bit of a similar issue a year ago with Perforce. This entire system is being used in a local setting across WiFi (potentially LAN) and as such I haven't configured HTTPS or any local DNS/DHCP settings (I'm still very new to this).

When on the server itself, everything works fine. I can access the site at localhost/owncloud and the client app works totally fine. But from another machine in my house I have zero access. The log on the admin page shows this Trusted domain error. "192.168.1.16" tried to access using "192.168.1.8" as host. error. I can ping the machine by it's wlan IP, but not the hostname as it keeps trying to use the disconnected eth port. I've recorded a screencap of what it looks like trying to connect through the web GUI and through the client app on my machine.

I'm really not sure what causes this. The best guess I have is that it keeps converting the IP into localhost/owncloud which doesn't exist on the non-server machines. Currently double checking the installation docs to see if I missed anything.

Also checking the Digital Ocean guide that I think the video used.


#2

Issue has been resolved. After going through Digital Ocean's guide (including adding SSL) once removing and reinstalling OwnCloud + databases everything works.