Problem loading page, reloading in 5 seconds after fresh install on new (vanilla) server

I did a clean install on a brand new server (ubuntu 22.04). I used the “quick install on ubuntu 22.04” page from the documentation.

The server is no vm, no docker. Instead of mysql I used pgsql. The install completed succesfully and everything looks fine. However I get the

“problem loading page, reloading in 5 seconds”

error. This happens after logging in and idling for more than 5 seconds. When you then click on a folder (in the default “bonus/example” files) I immediately get the error. There is

  • no request going over the network and thus
  • no log in any logfile (not apache log not owncloud log and not syslog or whatsoever)
    after the 5 seconds the requests show up in all logs and the page is received.

when you click around everything works fine, until you wait again for more then 5 seconds. The same error shows, no request, no logs, and after the timeout the pages reloads and the content shows.

I googled for this an read every thread about it (also on nextcloud forums) but nothing leads to the resolution… I tried 3 different browsers, completely removed the installation and database 3 times and it makes no difference. Logging in works and the settings pages work, adding users works, there are no warnings (except the “use https”). I use installed no plugings/apps, 1 browser (firefox) is a clean install with no addons/plugins.

I’m totally lost. How to proceed???

I can add: when you click the error immediately shows and there is a “request” shown in the networking tab of the browser. It is a PROPFIND /remote.php/dav/files/admin/Documents request, but this request is NOT shown in any logs on the server and receives no response: chrome says: (failed)


I also had this problem once. Unfortunately, I don’t remember on how I got it solved. I think it’s a JavaScript thing.

1 Like

Assuming you don’t have a firewall blocking things, it might be the web server. You can check some information for apache in Configure Apache for Manual Installation on Linux :: ownCloud Documentation

In addition, you can try a docker setup and check the differences with what you have.

1 Like

Ok, everything was configured as documented. (Except for the mod_uq.) This changed nothing. The last step involved using https so I activated the snakeoil certs and after accepting this in the browser the problem is gone… After going back to non-https the problem returned… I’m going to create a lets encrypt cert for this installation as this is better anyway.

Thanks goes to @jvillafanez

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.