Problem setting link passwords


#1

I shared a public link with a colleague by copy and pasting it into an email. The recipient needed a password however, although I didn't set a password. In the share link view I could not see what the password was, only a representation with stars: ********** Me trying to change the password resulted in multiple reloads of the password leading to a flood of password mails to the recipient.
Then I tried to share the link with my secondary mail account instead. This time I did not see a set password with stars, the input panel for the password was empty. When I tried to set a new password, the same reload and mail flood happened on in my email inbox.
Is this a bug? Any ideas how to prevent it? I'm using my universities owncloud network, so I'm not an administrator and my options might be limited.


#2

We'll likely need at least the ownCloud version you're using and very likely some screenshots of what you're doing (hide any private information) in order to figure out the configuration. This is needed in order to try to reproduce the problem and provide a workaround.


#3

Here is one screenshot. Fist I just put in my (secondary) email adress (no problem), then I tried changing the password, which led to the view changing rapidly multiple times between this screenshot and another view, where there is a longer password listed as stars*** whilst showing the loading sign. the result of this is 55 new mails in my inbox. I noticed this time there also was an error message on the mail-adress. I'm not sure if it was there before. It reads: "No users or groups were found for ".

The version I'm using is Nextcloud 12.0.5 on windows 7.


#4

Note that ownCloud is NOT nextCloud. This is a nextCloud problem, so feel free to open them a ticket.

As far as I know, ownCloud 10.0.6 doesn't have this problem: the mail is sent once on demand.