Problem to access owncloud

modifications

#1

Hi guys,
Recently, when I log in to my cloud, after logging in does not load the files ... the page remains white (with only the command bar visible) if I click on "personal" or "users" it makes me see various data ...
how can I reshape it?


#2

Please add screenshots, browser error console and server log - otherwise we cannot provide that much help


#3

I encounter this problem with all browsers I use: safari, firefox and chrome...

looking at the server log I noticed this ...
Error PHP Argument 8 passed to OC\Core\Controller\AvatarController::__construct() must implement interface OCP\Files\Folder, null given, called in /var/www/owncloud/core/Application.php on line 97 and defined at /var/www/owncloud/core/Controller/AvatarController.php#88 2017-09-27T14:38:44+00:00


#4

Which version are you using? Please consider upgrading to the latest version


#5

I run updates every 15 days (I have installed owncloud on raspberry and I upgrade every 15 days)
it is currently: ownCloud 9.1.6 (stable)


#6

10.0.3 is the latest and greatest :wink:


#7

how do I need to upgrade?


#8

https://doc.owncloud.com/server/10.0/admin_manual/maintenance/upgrade.html?highlight=upgrade#upgrade-options

I would recommend the manual upgrade

https://doc.owncloud.com/server/10.0/admin_manual/maintenance/manual_upgrade.html


#9

if you terminate the command: apt-get upgrade I get this message:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
chromium-browser libgl1-mesa-dri owncloud-files pix-icons pix-plym-splash
pixel-wallpaper pprompt raspberrypi-ui-mods rpi-chromium-mods sonic-pi
wolfram-engine xserver-xorg-input-all
0 upgraded, 0 newly installed, 0 to remove and 12 not upgraded.

how do I force the updates of these files?


#10

can you show me what you have in /etc/apt/sources.list.d/owncloud.list?

I suppose you are running Debian 8, right?


#11

Rasbian, I used the command: aptitude full-upgrade, seems to be making updates, then you put the file you asked for me


#12

I just did an upgrade from 9.1.6 to 10.0.3 with packages, I got the same error as you, and could upgrade using the full-upgrade command


#13

after updating ...


#14

the file owncloud.lost: deb http://download.owncloud.org/download/repositories/stable/Debian_8.0/ /


#15

Is your apache server running?

Also try to access the ownCloud via http


#16

Yes, installed apache server, redirects to https ...


#17

can you comment out the redirect and try access your owncloud?


#18

I do not remember how to proceed: P


#19

https://doc.owncloud.com/server/10.0/admin_manual/configuration/server/harden_server.html?highlight=redirect#redirect-all-unencrypted-traffic-to-https

You have to edit your /etc/apache2/sites-enabled/000-default.conf

in the virtual host 80 section. just comment out the redirect part


#20

either with the commented line, with the same line as the same error ...