Problem upgrading Owncloud, can't use occ app:disable templateeditor command


#1

Hello,

I’ve just upgrade my Owncloud Server to the latest stable version 10.0.9 using the Updater App. But after disabling the maintenance mode with the config.php and trying to upgrade, I’ve received an error. Looking at the internet I’ve just found that this error can be solved by using this command

sudo -u www-data php occ app:disable templateeditor

I put this command in the console but it says that occ is not a valid command.

I’m in Raspbian (I’m using a raspberry pi). And I use this command as pi user and in the /var/www/html/owncloud folder (where occ is)

What I am doing wrong?

Thank you


#2

Hi,
I had the same error with the last updrade.
For me, on Raspberry too, I done those steps
1/
cd /var/www/html/owncloud/
2/ To restart upgrade and see errors
sudo -u www-data php occ upgrade -vvv
3/To disable app (in my case templateeditor)
sudo -u www-data php occ app:disable templateeditor
4/ To restart upgrade
sudo -u www-data php occ upgrade -vvv
5/ To disable maintenance mode
sudo -u www-data php occ maintenance:mode --off

Best regards


#3

Thank you!! It worked!! Now my Owncloud works perfectly :slight_smile: