Problem with downloads!):


#1

Hello everyone lately I have noticed that my Owncloud can not finish the download. But apart from that everything is excellent is the only problem
System: Freenas 11.1 U2
Version of OwnCloud: 9.1.7
Storage method: SMB

So the problem is that I try to download a file (or anything else) after a certain time download is stuck and then eventually failed both in Google Chrome and in Firefox I also tried to download different files do not really matter or even different users no change in the past Use local storage but moved to SMB. I tried a few things that did not really work but I noticed that while I continue to refresh to a web page then downloading does not stop so what I think the server simply disconnects while downloading And that's very strange. Because I have access to OwnCloud and everything looks fine no error messages, except that downloaded gets stuck if I do not refresh the page every few seconds
I really do not know how to solve it if you can help me I will thank you very much

If you need more information or details do not hesitate to say
(Local storage also had the problem)

Thanks Itay


#2

Hey,

sounds to me that you are running in to a timeout.

can you try this and report back if it helped?

https://doc.owncloud.com/server/10.0/admin_manual/configuration/files/big_file_upload_configuration.html?highlight=timeout#configuring-your-web-server


#3

Sorry that it took me so much to respond.
I tried to follow the guide but I could not find the lines anywhere
"php_value max_input_time 3600"
"php_value max_execution_time 3600"
And yet it's really like you said that my problem, is that I go timeout so it's the things I need to change and not really have been successful in finding them.


#4

There's something that knows maybe how to fix it ???


#5

Then you have to add such lines, according the docs. Otherwise, the default values will be used, but they might be too small.


#6

Maybe there are also additional timeouts to those like e.g. within your Webserver or similar.


#7

I went through the manual linking up dozens of times. And I have no idea where to write these lines, no matter how many times I searched and went through this guide and also have files for example user.ini that I can not find anywhere


#8

Maybe you have missed the following text in the linked documentation:

Set the following two parameters inside the corresponding php.ini file (see the Loaded Configuration File section of PHP Version and Information to find your relevant php.ini files)

php_value upload_max_filesize = 16G
php_value post_max_size = 16G

which explains that you need to configure this within your php.ini. The link within this text points to https://doc.owncloud.com/server/10.0/admin_manual/issues/general_troubleshooting.html#label-phpinfo where you can find additional information how to locate this php.ini with a phpinfo.php file.

With this info the work for you starts and you need to locate this php.ini in your environment. :slight_smile: This is specific to your setup and might differ between every user here.

As this configuration is also something PHP specific and the ownCloud documentation gives just some generic pointers maybe having a look at the PHP manual gives you some more information: https://secure.php.net/manual/en/index.php


#9

But when reading the documentation again it seems that it is misleading and only mention a .htaccess or .user.ini file. Personally i wouldn't use that files and just use the "global" php.ini where i had given some pointers how to locate it above.

I think the syntax in that php.ini might differ from the examples provided in the documentation so maybe you need to have another look into the PHP manual for the correct one.


#10

Ok thanks I will look for the file and notifies you


#11

This is the only file I found with that name. I do not think this is the right file.

php.ini


#12

I don't think as well. Mine has around 2000 lines, not only two like yours.


#13

This is the only file I found with that name. If that's not it, what do we do?


#14

I think thats uncommon, such a file should definitely there. As you're running on FreeNAS maybe you could ask at a support forums related to that OS?

It could be possible that users running the same OS have way more knowledge on such configurations on that OS. They probably could also better help on how to apply the recommendations of the linked documentation.


#15

Ok thank you very much for the help, I will try to ask in their forums.


#16

As an alternative maybe you could still try to locate the file based on the phpinfo.php suggestion above. Mine has e.g. "/etc/php/7.0/fpm/php.ini" in the "Loaded Configuration File" column. Thats where i had raised those limits.


#17

I saw an update to 9.1.8 so I updated (my previous version was 9.1.7) and then after the update I searched again after php.ini. And luckily I found two files, the link I have attached is the two files you can tell me with the correct files I need? And are max_execution_time and max_input_time these things I need to change should solve my problem?

php.ini-files

The first file is the file that appears in: usr \ local \ etc
The second file appears at: usr \ pbi \ owncloud-amd64 \ etc


#18

I think this is nothing some one from this forums can tell you. But if you scroll some posts higher you will find some info about a phpinfo.php (suggested twice) which gives you the info which php.ini your PHP is using.

Maybe it could solve your problem but i think this is nothing what some one can guarantee you. If you check the documentation in https://doc.owncloud.com/server/10.0/admin_manual/configuration/files/big_file_upload_configuration.html there are quite a lot other timeouts mentioned there in e.g. your webserver.

As other components like a SMB server is in use additional network related timeouts might play an additional role.