Problem with intl.php Hash on ubuntu server 20.04

I Finished installing Owncloud server on my machine, very impressive by the way. I was able to fix all the error messages except the code integrity check for “lib/composer/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php” it all comes from ubuntu’s repository and re-install doesn’t fix the problem. Wondering why the hash check is not valid and what I can do to fix it. I can’t find another intl.php outside of ubuntu’s repo and frankly, only want to use the repo. Can this be ignored or is it a real risk? Thank you in advance for your time, information and help.

Steps to reproduce

1.install ubuntu 20.04 (Linux)
2.install and setup owncloud’s dependencies from Ubuntu’s repository (Apache Mysql Php)
3.install owncloud
4. login as admin

Expected behaviour

The hash check for “lib/composer/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php” should match

Actual behaviour

The hash check for “lib/composer/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php” doesn’t match.

Server configuration

Integrity error file:

contents of config/config.php will not be shared here.

config_report.json is 8900 lines, I uploaded it on github, it has all the server and software info.


Did you restart you web server after reinstalling from ubuntu’s repository ?
sudo apt-get install php-intl && sudo /etc/init.d/apache2 restart

1 Like

I just tried again, I was using php7.4-intl

sudo systemctl stop apache 2
sudo apt autoremove php7.x-intl
sudo apt purge php7.x-intl
sudo apt install php7.4-intl
sudo systemctl restart apache2

where x is * to remove any other 7. version.

Rescanned the files, still the exact same messages and hash error so I removed php7.4-intl again and tried with the one in your line

sudo systemctl stop apache2
sudo apt autoremove php7.4-intl
sudo apt purge php7.4-intl
sudo apt install php-intl
sudo systemctl restart apache2

It bundled php8.0-intl along with it but it still didn’t work, same hash error message after a rescan


i don’t think that this can be fixed by updating some debian packages. Instead i think you need to follow this suggestion:

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix

and follow this: