Problem with remaining quota display (10.0.2)


#1

Hello there,

I have the following issue: When I click into user -> settings, then my remaining quota should be displayes (e.g. "you use 12.2 GB of the available 20 GB").

Instead, the thing that I get is: "you use 0 B of the available 6.7 GB", although my raspberry pi 3 setup has got a capacity of 30 GB. -> See image below


The command "df -h" responds: "Size: 30 G, Used 20 G".
I know, that owncloud will never display the same as the command from above because of not counted thumbnails, system files etc, but the message from above is weird! How can I fix this?

Thanks for your help!


#2

I just realized that, in addition to the issue above, owncloud is unable to display the correct size of some subfolders. Instead, the simple message "outstanding" is displayed:

As you can see, the size of the folder "Literatur" is displayed as <1 KB, but when i position the curser over it, it displays a negative (!) value, which is in fact the correct quantity. What's going on here?


#3

try to upload a file within that folder 'Literatur' - maybe this triggers recalculation of the folder size and fixes to overall quota ....


#4

thanks for replying.
that doesn't work, I tried this before, but the displayed messaged remains "outstanding". When I go into the "Literatur" folder, the sizes of all subfolders are displayed correctly.


#5

do you have shell access? then you can run ./occ files:scan -p /files/$user/path/to/Literatur


#6

I run owncloud on my raspberry pi 3 with ssh shell access, but I am quite new to Linux. How can I run your command? As it seems it is not a normal command for a putty shell?


#7

ok i managed to run the command by doing sudo -u www-data /var/www/owncloud/occ files:scan --path XXXXX/Literatur/
but the problem could not be solved this way :confused:


#8

does anybody have some new ideas here?


#9

raspberry is a 32 bit system - is your folder size beyond this limit?


#10

I have a 64 GB SDXC Card and my folder has a size of 19 GB (according to console command df -h). I didn't know that there is a folder size limit coming with this 32 bit thing?? How high is this limit?


#11

A 32 bit integer has a max value of 2,147,483,647 - which is ~2GB.
This is the reason why you don't see the folder size afaik


#12

You could try with https://github.com/owncloud/core/pull/28654, you might need to run occ files:scan --all to readjust the sizes in the database


#13

Awesome, this solved my problem perfectly, thank you!!