Problem with share folders after update to 10.0.7


#1

Hi support,

After update my owncloud from 9.1.7 to latest verion my shares not working properly,
can you give me instruction how to enable shares?

Thanks,


#2

Hi there,

could you describe the problem a little bit more?


#3

Hi Dmitry,

I was update the owncloud from version 9.1.7 to 10.0.7. I had setuped shares folders with others user, after update the shares folder not showing to the other users this is my problem.

P.S. before update I disabled all application in version 9.1.7, i think that my problem is share application is not includet in version 10.0.7

If the applications are not disabled, the update process crashed!
Thanks


#4

How did you update?

Did you use the web updater or the tar balls?


#5

Hi Dmitry,

The update was via web updater, i was try first with the tar.bz2 files, but the problem was applications, after disabling the applications on version 9.1.7 the update was successiful

Thanks


#6

This is the images about problem.

owncloud 9.1.7

owncloud 10.0.7

on the version 9.1.7 the share working, but on the version 10 share is not working, Why?


#7

Have you enabled the sharing app?

I suspect your database is corrupt or damaged. Without the database you can't have shares.


#8

Hi Dmitry,

I think some of tables was deleted when db scheme was updated with the new version of owncloud 10

Can you send me instruction how to update owncloud 9.1.7 to version 10, with included applications from 9.1 (apps folder)??

Thanksk


#9

https://doc.owncloud.com/server/10.0/admin_manual/maintenance/manual_upgrade.html

You have to copy the app folder outside of the owncloud folder and after the upgrade copy the apps back inside.


#10

Also the share settings was enabled, but when i open market for installing new application share apps not showing.


#11

I follow this tutorial, but when try to login i have internal server error

P.S. the login page is working


#12

Well,

You could investigate the cause of the error if you look at the ownCloud.log


#13

Hi Dmitry,

At the owncloud.log i don't saw any errors, after refresh the web page, i have errors at the /var/logs/apache2/owncloud.logs this log is define at the apache virtual hosts


this is error logs file

Thanks


#14

If your owncloud server is not working, and you get an error on the log in page, you have to have an error in the owncloud.log file. is it empty or don't you see any errors?


#15

Hi Dmitry,
The problem with shares files are solved, but now i have another problem, I uses LDAP users , but when i open shared folder, instead showing user_name for shares, its shows them ID, how can i solve that?

version 10.

version 9

Thanks


#16

In owncloud, user authentication, LDAP server configuration, expert tab.
You have to set the Internal User Name Attribute to Samaccount name.

https://doc.owncloud.com/server/10.0/admin_manual/configuration/user/user_auth_ldap.html?highlight=ldap#expert-settings


#17

Hi Dmitry,

I find the problem, only need login with the LDAP user
The problem is solved

Thank you