Problems to connect clients to the OwnCloud Server 10.0.9 (stable) @ CentOS7


#1

Hallo Zusammen…

Nach einem Fehlgeschlagenen Update auf 10.0.9 (Startseite hin in der Meldung “Cloud wird gewartet” fest und es ging nix mehr) hab ich mich dazu entschieden, die OwnCloud einfach mal neu aufzusetzen…
Gesagt getan…

OwnCloud 10.0.9 (stable) via Repo installiert (WebInstaller gibts ja scheinbar nicht mehr)
Beim Versuch drauf zuzugreifen, festgestellt das er das irgendwohin geschmissen hat wo es bei einem Server mit installiertem Plesk nicht erreichbar ist…

Auf die Suche gemacht und gefunden in
/var/www/html/owncloud/

Da die files wie oben beschrieben an dieser Stelle nicht erreichbar sind, kopiert nach /var/www/vhosts/domail.tld/cloud.domain.tld/httpdocs/

Somit war zumindest das Webinterface über https://cloud.domain.tld/ erreichbar…

Dort die Einrichtung weitergeführt, DB Username, DB Passwort, DB Name, Username & Passwort in die Eingabemaske eingetragen und fertig gestellt (benutze MySQL DB)

Cloud läuft - dachte ich zumindest…

Nachdem ich dann alle Sicherungen (Kalender, Kontakte, etc…) wieder eingespielt hatte ging es daran die Mobilen Clients (MacBook, iPhone) wieder mit der Cloud zu verbinden…

Das funktioniert jedoch ums verrecken nicht…

Ich soll nun ein zusätzliches Passwort für die Clients im Webinterface erstellen und dieses Passwort verwenden, OK… Zusätzliches Passwort generiert, im der OwnCloud App (MacBook) eingetragen & weiter…
Geht nur nicht… Bekomme immer wieder die Aufforderung das Passwort einzugeben…

Meldung: “Zugang vom Server nicht erlaubt. Klicken Sie hier zum Zugriff auf den Dienst mithilfe Ihres Browsers, so dass Sie sicherstellen können, dass Ihr Zugang ordnungsgemäß funktioniert”

Da hänge ich nun fest…

Hat jemand ne Idee wie das zu lösen ist?

OwnCloud: 10.0.9 (stable)
Server: CentOS 7.5.1804 (core)

  • Plesk Onyx 17.8.11 Update #18
  • PHP 7.2.9
  • MySQL 5.5.60

#2

Stichwort CORS, würde ich mal raten.

Du musst eventuell unter Settings->Security noch Domains freischalten.


#3

Das versuch ich mal…

Einfach nur nach dem Prinzip “subdomain.domain.tld”?

LG


#4

So, ein Problem hab ich gelöst…
Beim Kopieren an den anderen platz, wurden ein paar versteckte Dateien nicht mitkopiert…

Mit dem Owncloud Client kann ich mich nun verbinden… Hab jetzt "nur2 noch das Problem mit dem Kalender & den Kontakten…