Problems with External Storeage (SFTP)


#1

Hi,

I just installed ownCloud on my Root-Server.

So far, everythinks works perfect.

Just the SFTP-Connections to my External Storeage makes problems:
When I try to upload bigger files (e.g. > 25 MB) the file never will be uploaded to the external storeage. Smaller files are working and even bigger files (> 250MB) are working when I upload them directly to my server (not external stoareage).

I think there is a problem that my ext. storegage using the streaming connection or something like that. Can I somehow activate the “temp-folder” for the SFTP connection?`

Thanks!
Regards.


#2

Hello,

Just a stab in the dark, do have mod_securety running?

If so disable and try again.

Also look here: https://doc.owncloud.org/server/10.0/admin_manual/issues/general_troubleshooting.html#logfiles?to=admin-logfiles

  • Mike

#3

Hi, it was activated before, but I disabled is, because I had to much problems.

So, the answer is “no, I´ve mod_sec not active right now”


#4

Hello,

Did you see any of the other modules that are troubles makers in the list running on your server?

  • Mike

#5

No, in my opinion not. Which one do you mean/know?

I also tried to mount via SSHFS and then connect to it via “Ext. Storeage” -> “Local”, but that did not work. I think beacuse of the permissions…


#6

Hey,

maybe this previous hint could give you some more info on your issue?


#7

Thanks, but I did a lot of the stuff described there…

Is it possbile to use a “sshfs” mounted folder as “local” ext. storeage?
Or is it possbile to activate upload using the temp-folder fpr SFTP?


#8

Hey,

i think what the documentation is trying to tell you is to look into your log files to see where the error / issue from failed uploads above a specific size is coming from.

Without a hint from the logfiles everyone probably can only wildly guess around why you see this issue. :confused:


#9

Hi, it works now. But I did the workarround with sshfs.

Means, I mounted the ext. storeage with sshfs and then connect to it via ownCloud.
Directly connecting via SFTP didn´t work for me.