Problems with OwnCloud after migration

hosting

#1

Hello,

Last night I migrated my web server from a VPS to an Amazon EC2.
All my WHM accounts were migrated using the transfer tool and everything seems to have migrated fine, except for OwnCloud. My windows app keeps asking for a password which I am providing but it just isn’t letting me in.
I have tried adding a new account and it gives me another error "Access forbidden by server. To verify that you have proper access, click here to access the service with your browser. When I click “Here” it just takes me to the login page where I can log in. Everything is find when using the web interface, I just can’t reconnect my windows app. I have also tried using the OwnCloud App password which also doesn’t work.

I also have an error in the web app that says some files haven’t passed integrity test, when I click view files, It’s literally every file that has failed tests. I’m unsure why this is? The server hostname is the same, the account names are the same, everything was mirrored from the old server. The only thing I think it could be is the IP address, but I don’t see why.

Is there are way to reinstall owncloud? or repair the installation?

I really can’t get this app to connect and that’s all I want to do.

Thanks


#2

Maybe you can compare the configuration of the webserver and PHP from the VPS with the one from the Amazon EC2 instance to see the differences between both configurations and to see why both are behaving differently? There is probably something different in the new configuration blocking the access of the windows / mobile client.


#3

Hi Tom, the php configs are slightly different. I couldn’t mirror the server configurations because I am running CentOS7 on the new server. I do believe that the OwnCloud files need to be validated or somehow reinstalled. Is there are simple way to run a repair on OwnCloud? or should I just reinstall OwnCloud?


#4

I’m not sure if the failed integrity test is causing the failed login. I think this is more related to the webserver configuration or similar.

But you could try to fix the integrity message first by following the documentation i have found here:

https://doc.owncloud.org/server/latest/admin_manual/issues/code_signing.html#fixing-invalid-code-integrity-messages