Public Links for anonymous upload do not work after update to 10.0.7.2


#1

Steps to reproduce

  1. I updated my self hosted owncloud to version 10.0.7.2
  2. I had some directories shared as public anonymous file upload areas
  3. After update I can drop a file in the box, it uploads and then I get an error message and a login/password popup from owncloud.

Expected behaviour

Anonymous upload should work like before.


#2

Hey,

i’m not sure if it is a good idea to update to 10.0.7 where 10.0.10 is current:


#3

Very good question :slight_smile: My problem is that the update to 10.0.10 stopped with this error message:

So I’m stuck with 10.0.7 :frowning:


#4

Hey,

i had read some discussions where it was recommended to not use the updater app. Personally i’m doing the manual update like described in the documentation which works quite reliable for me.


#5

I get the same POP UP asking for user name and password all the time. Worked perfectly on previous versions. It is almost like the shared link is hidden. Older versions you can copy it to the clipboard real easy, the 10.0.10 version it’s almost hard to find the shared link. And when you get it, it just prompts for user name and password. Looks like my OneDrive will have to take over. Too many variables and changes when doing updates.
Thanks.


#6

as @tom42 said or wrote ,
it is recommended to upgrade manually not over the Web-UI

please follow these instructions
https://doc.owncloud.org/server/9.1/admin_manual/maintenance/manual_upgrade.html