QNAP Owncloud von 8.0.4 auf 9.x updaten


#1

Hallo,
ich suche schon seit längerem nach einer Möglichkeit auf meiner QNAP TS-253A Owncloud von 8.0.4 auf 9.x upzudaten. Leider habe ich im Netz bisher nur Informationen gefunden, dass dies bisher wegen einer fehlenden libxml Version 2.7.0 nicht funktionieren soll. Daher meine Frage an das Forum - stimmt das noch oder gibt es mittlerweile die Möglichkeit.

Schritte zum Reproduzieren
1.
2.
3.

Erwartetes Verhalten
Sag uns was passieren sollte ...

Aktuelles Verhalten
Sag uns was stattdessen passiert ...

Server-Konfiguration
Betriebssystem:
Webserver-Typ:
Datenbank-Typ:
PHP-Version:
ownCloud-Version (siehe ownCloud Administrationsseite):
Von einer älteren ownCloud-Version aktualisiert oder neu installiert?:
Sonderkonfigurationen (external storage, external authentication, reverse proxy, server-side-encryption):

ownCloud log (data/owncloud.log)

Bitte füge mögliche Fehler in den folgenden Code-Block, siehe https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 für mehr info.

Integrity status für oC9+

Logge Dich als Admin in Deine ownCloud Instanz ein, öffne
http://example.com/index.php/settings/integrity/failed
und kopiere das Ergebnis hier.

#2

Auf andere noch unterstützte Versionen (8.1 oder 8.2) müsstest du updaten können, da die Einschränkungen erst ab OC 9.0 gelten. Über das QNAP-System wirst du hier vermutlich relativ wenige Experte treffen, da gibt es bestimmt bessere Anlaufstellen.


#3

Hallo, danke für deine Info, leider ist es mir auch nicht gelungen auf 8.1 oder 8.2 upzudaten, da ich keine entsprechende Version für QNAP gefunden habe.


#4

Manuell müsste es gehen. Oder du fragst die Leute, die das Pakete ursprünglich bereit gestellt haben, ob sie das aktualisieren wollen.


#5

Auch hier nochmal ein Quote aus https://central.owncloud.org/t/login-im-browser-nicht-moglich/5012/18:

Es ist auch ein weit verbreiteter Mythos, dass nur oC 9.x libxml 2.7.0 oder höher benötigt. Diese Version wurde schon immer benötigt[1] (so lange man per WebDAV, CalDAV oder CardDAV auf oC zugreift), nur wurde eben die Überprüfung darauf mit oC 9.x eingebaut [2].

[1]

This has broken before as well but we just didn't notice because peoples are not necessarily using our sync clients. Now with WebDAV in core also the web interface will break.

[2] https://github.com/owncloud/core/pull/23189

Generell gilt: Hände weg von Systemen, die es nicht schaffen eine library wie libxml, die vor knapp 9 Jahren veröffentlicht wurde (Siehe http://www.xmlsoft.org/news.html) bereit zu stellen