Quotas do not apply

Hello,

I have just received several reports from people telling me that their storage space is full.

After verification, it seems that the quota no longer applies. I customized the quota for some users (example 10 GB).

Once the user has reset a new connection to the server, the quota and reset automatically and go from 10G to 5G (default).

I modify the value of the field (quota) of the oc_accounts table directly on 10G and after a new synchronization of the Owncloud client, the value returns to the default value (5G).

This after an update, I’m in owncloud version 10.0.2-1.1,

Debian 8.11
PHP 7.3.4-1+0
Mysql 5.5.62-0

settings/integrity/failed
Résultats

  • editdoc
  • EXCEPTION
  • OC \ IntegrityCheck \ Exceptions \ MissingSignatureException
  • Données de signature non trouvées.
  • conversations
  • EXCEPTION
  • OC \ IntegrityCheck \ Exceptions \ MissingSignatureException
  • Données de signature non trouvées.

Thanks in advance for your answers, waiting to be able to exchange.

Mosley

There have been several changes around quotas during 10.0.x, so please upgrade your ownCloud to a more recent version and retry. Your problem might be already solved in a newer version.

If the problem persist, try disabling any application that wasn’t installed with ownCloud, specially 3rdparty ones, and retry. It’s possible that some app is causing problems, and in any case, it would help to narrow down where the problem is.

1 Like

Hello,
thank you for your return, I take note and will come back to you.

Hello,

For information, I have a dev server under debian 9.6 with owncloud 10.0.2-1.1. quota management works well.

Crémos

Hello,

I’m on the repository: deb http://download.owncloud.org/download/repositories/production/Debian_8.0/ /
with the latest version of my owncloud files owncloud-files 10.1.1-1 + 1.1.

On the Owncloud website, I am offered to install the ownCloud Community Edition link for a debian8.0 file:
deb http://download.owncloud.org/download/repositories/10.0/Debian_8.0/ /

I’m a little lost, what is the good link for the latest version of owncloud for debian 8.11
Thank you

PHP 7.3.4-1+0

This isn’t supported yet, so it could cause unforseen problems in ownCloud. It might be related to your problem.

Relevant analysis is the version of PHP7.3 that has problem. I downgrade my version of PHP7.3 to PHP7.1 that seems to work.
Thank you for your availability and analysis.

Hello,

I just received a feedback from teachers telling me that their quotas were again reset (default 5GB) after syncing with the Owncloud client.

I’m currently in debian 8.11 and PHP 7.1.30 with the latest version of owncloud-files 10.1.1-1 + 1.1 from the repository: deb http://download.owncloud.org/download/repositories/10.1.1/Debian_8.0 I

I would have to upgrade my server from debian 8.11 to debian 9.9 and change the Owncloud repository to: deb http://download.owncloud.org/download/repositories/production/Debian_9.0/ to upgrade to owncloud-files 10.2.0-1 + 1.1

I did not see anything in the changelog regarding a malfunction of the quota function.
Do you think this will solve the problem of the quota setting?

Regards

Hello,

I am upgrading my server to a debian 9 with an update of owncloud to owncloud-files 10.2.1-1 + 1.3.

Steps to reproduce:
./occ upgrade.

Expected behaviour:
Upgrade takes some time but usually within reason (never longer than 5 minutes in the past).

Actual behaviour:
“Starting code integrity check…” - and it stalls - tested for 2h30 hours.

Do you think this is a server environment problem or dependencies?
Thank you in advance for your answers.