Rainloop webmail version 5.2 available but not on ownCloud Marketplace

in July 2019, rainloop published version 5.2 of their app, it can be found here on github: https://github.com/RainLoop/rainloop-webmail/releases

On ownCloud marketplace, there is until now only version 5.1 available: https://marketplace.owncloud.com/apps/rainloop

So I checked the 5.2. version from github.
There are 2 versions available, 5.2 and 5.2-standard. There are some differences in the code in between those versions and the 5.2 version is licensed as AGPLv3 while 5.2-standard is licensed under “RainLoop Software License” so maybe thats for their commercial users?! Did not check further here.

First, the max version in the file /appinfo/info.xml must be edited in line 14, it still sais 9.2 here :wink: I think you all know the trick …

After copying the new version to the owncloud app-folder, you get redirected to the database upgrade process and performing thats it.

I tested the app successfully on ownCloud 10.0.10 and 10.1.1.

Its not working on ownCloud 10.2.1, here I get the following errors in the owncloud.log:
{“reqId”:“gYAVuoJgNWtHeq00BvnZ”,“level”:3,“time”:“2020-01-05T20:31:43+00:00”,“remoteAddr”:“IP-address”,“user”:“username”,“app”:“index”,“method”:“GET”,“url”:"/index.php",“message”:“Exception: {“Exception”:“Error”,“Message”:“Class ‘OCP\\Config’ not found”,“Code”:0,“Trace”:”#0 \/var\/www\/owncloud\/lib\/private\/legacy\/app.php(239): require_once()\n#1 \/var\/www\/owncloud\/lib\/private\/legacy\/app.php(190): OC_App::requireAppFile(‘rainloop’)\n#2 \/var\/www\/owncloud\/lib\/private\/legacy\/app.php(124): OC_App::loadApp(‘rainloop’)\n#3 \/var\/www\/owncloud\/lib\/base.php(896): OC_App::loadApps()\n#4 \/var\/www\/owncloud\/index.php(54): OC::handleRequest()\n#5 {main}",“File”:"\/var\/www\/owncloud\/apps\/rainloop\/appinfo\/app.php",“Line”:16}"}
{“reqId”:“H110XhypsoT2q3Wnl7fs”,“level”:3,“time”:“2020-01-05T20:31:44+00:00”,“remoteAddr”:“IP-address”,“user”:“username”,“app”:“PHP”,“method”:“GET”,“url”:"/ocs/v2.php/apps/notifications/api/v1/notifications?format=json",“message”:“Error: Class ‘OCP\Config’ not found at /var/www/owncloud/apps/rainloop/appinfo/app.php#16”}

@DeepDiver1975 according to the information in ownCloud Marketplace, you uploaded the app there a while ago. Can you add version 5.2 with the updated appinfo/info.xml there with compatibility up to 10.1.1? Thank you!

If someone can help fixing the code of the app to make it work with newer ownCloud versions, that would be great for sure :smiley:

Best regards,

1 Like

Just updated to owncloud 10.1.1 with rainloop 5.2, and confirming all good.
Tried as well then the 10.2.1, and ran into same error.

I actually found kind of a way of replacing such calls in the src code, it would worth a try:

Have raised the issue on github: https://github.com/RainLoop/rainloop-webmail/issues/1960


Thank you for your feedback and confirmation of this issue. Looking on the activity on the rainloop github, the repo owner mostly merges pull requests and releases new versions from time to time.

@albansch your way changes several OC core files, but normally it should better be fixed on app level, right?!

There is a fix available which might be included in the next Rainloop webmail release.

I merged this fix with the rainloop version 5.3.0 (release 1.14.0 from January 2020) and tested it on my ownCloud 10.3.2 and its working! I also checked ownCloud version 10.4.1 and I confirm its working there as well.


@Plastikschnitzer have you tried with latest version of owncloud > 10.4.1?

Yes, I am running my manually fixed version of 5.3.0 rainloop together with ownCloud version 10.5.0 and 10.6.0. and its working perfectly fine as expexted.

However the latest official version of Rainloop (1.15.0) does not contain any package for ownCloud any more. I used this occasion to ask for the reason why: https://github.com/RainLoop/rainloop-webmail/issues/2064

1 Like