Recovering data with deleted config files

I set up an Owncloud Infinite Scale server yesterday with docker based on the container setup documentation. I did not change any of the parameters except the hostname. After the server was set up I transferred some files to the server and enabled virtual files.

I then tried to change the password and username of the server, but I got an error saying an error occurred and it was not able to change save the changes. Later when trying to access the server I was no longer able to access it. I believe the password or username had been changed.

Stupidly I deleted the config files (ocis-config folder), but not the data folder in hope of just setting it up again with new config, but keep my files. I have not been able to do this.

Is it possible to recover the data saved to the server in the /ocis-data without having the original /ocis-config folder with the ocis.yaml file?

I think I was able to restore the original ocis.yaml config file, but I am not 100% sure. I tried running the server with the config file and I do not get any error messages. When I open up the web gui I get the error: “http: TLS handshake error from remote error: tls: unknown certificate”, but I believe I also got this when everything was working correctly as I have not set up a certificate.

However, I am still not able to log in to the server. I believe I was able to change the admin username when messing the the settings which I do not remember. When testing with the username I believe I changed it to I get the error: “message”:“invalid credentials”.

Is there a way to reset the password of this user, create an admin user or another way to access the GUI when I don’t remember the password or possibly the correct username?

You can set a new admin password with ocis idm resetpassword.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.