Redis Exception - NOAUTH Authentication required

Steps to reproduce

  1. Attempt to open or upload file or create new folder;
  2. Opening file redirects to “Internal Server Error” page;
  3. Uploading or creating triggers “NOAUTH Authentication required” popup.
  4. sudo cat data/owncloud.log | grep AUTH indicates Redis Exception

Expected behaviour

Tell us what should happen
File should just open or upload or folder should be created.

Actual behaviour

Authentication error is thrown indicating Redis Exception.

Server configuration

Operating system: Ubuntu 20.04

Web server: Apache2

Database: MySQL

PHP version: 7.4

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install: fresh

Where did you install ownCloud from: ```
owncloud community owncloud-10.5.0.tar.bz2

**Signing status (ownCloud 9.0 and above):** Let's Encrypt HTTPS

Login as admin user into your ownCloud and access

The content of config/config.php:

    "basic": {
        "license key": "***REMOVED SENSITIVE VALUE***",
        "date": "Thu, 22 Oct 2020 20:15:34 +0000",
        "ownCloud version": "",
        "ownCloud version string": "10.5.0",
        "ownCloud edition": "Community",
        "server OS": "Linux",
        "server OS version": "Linux ubuntu-s-1vcpu-1gb-nyc1-01 5.4.0-52-generic #57-Ubuntu SMP Thu Oct 15 10:57:00 UTC 2020 x86_64",
        "server SAPI": "apache2handler",
        "webserver version": "Apache\/2.4.41 (Ubuntu)",
        "hostname": "",
        "logged-in user": "admin_michael"
    "stats": {
        "users": {
            "Database": {
                "count": 2,
                "seen": 2,
                "logged in (30 days)": 2
        "groups": {
            "OC\\Group\\Database": 2
    "config": {
        "instanceid": "octe9oh7qpqz",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
        "datadirectory": "\/var\/www\/\/data",
        "overwrite.cli.url": "https:\/\/",
        "dbtype": "mysql",
        "version": "",
        "dbname": "owncloud",
        "dbhost": "localhost",
        "dbtableprefix": "oc_",
        "mysql.utf8mb4": true,
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "logtimezone": "UTC",
        "apps_paths": [
                "path": "\/var\/www\/\/apps",
                "url": "\/apps",
                "writable": false
                "path": "\/var\/www\/\/apps-external",
                "url": "\/apps-external",
                "writable": true
        "installed": true,
        "memcache.local": "\\OC\\Memcache\\APCu",
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "localhost",
            "port": 6379

List of activated apps:

  - calendar: 1.6.4
  - comments: 0.3.0
  - configreport: 0.2.0
  - contacts: 1.5.5
  - dav: 0.6.0
  - federatedfilesharing: 0.5.0
  - federation: 0.1.0
  - files: 1.5.2
  - files_external: 0.7.1
  - files_mediaviewer: 1.0.3
  - files_sharing: 0.13.0
  - files_trashbin: 0.9.1
  - files_versions: 1.3.0
  - firstrunwizard: 1.2.0
  - market: 0.6.0
  - notifications: 0.5.2
  - provisioning_api: 0.5.0
  - systemtags: 0.3.0
  - tasks: 0.9.7
  - updatenotification: 0.2.1
  - encryption
  - external
  - user_external

Are you using external storage, if yes which one: local/smb/sftp/… no

Are you using encryption: yes/no no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/… no

Client configuration

Browser: Firefox

Operating system: Ubuntu 20.04


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

sudo cat data/owncloud.log | grep NOAUTH

{"reqId":"same as indicated by phpinfo() diagnostics","level":4,"time":"2020-10-22T19:55:59+00:00","remoteAddr":"","user":"*********","app":"webdav","method":"GET","url":"\/remote.php\/webdav\/ownCloud%20Manual.pdf","message":"Exception: NOAUTH Authentication required.: {\"Exception\":\"RedisException\",\"Message\":\"NOAUTH Authentication required.\"

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

BTW, I did attempt to set up a couple two-factor apps from the Marketplace and then removed them. I don’t know if the problem existed before.

If you have made any changes in configuration file then don’t forget to restart redis service sudo service redis-server restart

1 Like

The problem is still the same after restarting the redis server. Thanks anyway.

It seems you’re connecting to a redis server which requires authentication, but you aren’t providing any.

Assuming redis is in a safe environment, you can disable the authentication mechanism in the redis server to allow anyone to connect. Of course, you should ensure that only ownCloud can access to that redis server.

If you still want to authenticate against the redis server, you can try the following configuration:

'redis' => [
  'host' => 'localhost',
  'port' => 6379,
  'password' => [
    'user' => 'username',
    'pass' => 'password'


'redis' => [
  'host' => 'localhost',
  'port' => 6379,
  'password' => 'password',

Everything works now. Thanks!