Redis server provokes errors in owncloud

Server configuration

Operating system: TwisterOS

Web server: nginx/1.14.2

Database: 10.3.27-MariaDB-0+deb10u1 Raspbian 10

PHP version: PHP 7.3.27-1~deb10u1

ownCloud version: 10.7.0.4

The content of config/config.php:


An unhandled exception has been thrown:
RedisException: Connection refused in /var/www/owncloud/lib/private/RedisFactory.php:117
Stack trace:
#0 /var/www/owncloud/lib/private/RedisFactory.php(117): Redis->connect('localhost', 6379, 0)
#1 /var/www/owncloud/lib/private/RedisFactory.php(139): OC\RedisFactory->create()
#2 /var/www/owncloud/lib/private/Memcache/Redis.php(37): OC\RedisFactory->getInstance()
#3 /var/www/owncloud/lib/private/Memcache/Factory.php(131): OC\Memcache\Redis->__construct('8433db1f9b85fe2...')
#4 /var/www/owncloud/lib/private/Server.php(731): OC\Memcache\Factory->createLocking('lock')
#5 /var/www/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(118): OC\Server->OC\{closure}(Object(OC\Server))
#6 /var/www/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(108): Pimple\Container->offsetGet('LockingProvider')
#7 /var/www/owncloud/lib/private/ServerContainer.php(86): OC\AppFramework\Utility\SimpleContainer->query('LockingProvider')
#8 /var/www/owncloud/lib/private/Server.php(1511): OC\ServerContainer->query('LockingProvider')
#9 /var/www/owncloud/lib/private/Files/View.php(124): OC\Server->getLockingProvider()
#10 /var/www/owncloud/lib/private/Server.php(179): OC\Files\View->__construct()
#11 /var/www/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(118): OC\Server->OC\{closure}(Object(OC\Server))
#12 /var/www/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(108): Pimple\Container->offsetGet('EncryptionManag...')
#13 /var/www/owncloud/lib/private/ServerContainer.php(86): OC\AppFramework\Utility\SimpleContainer->query('EncryptionManag...')
#14 /var/www/owncloud/lib/private/Server.php(942): OC\ServerContainer->query('EncryptionManag...')
#15 /var/www/owncloud/lib/base.php(754): OC\Server->getEncryptionManager()
#16 /var/www/owncloud/lib/base.php(668): OC::registerEncryptionWrapper()
#17 /var/www/owncloud/lib/base.php(1058): OC::init()
#18 /var/www/owncloud/console.php(74): require_once('/var/www/ownclo...')
#19 /var/www/owncloud/occ(11): require_once('/var/www/ownclo...')

**Are you using external storage, if yes which one:**/media/ownclouddrive

**Are you using encryption:** yes


### Client configuration
**Browser:** Chrome

**Operating system:** Windows 10 

Hello again,
I have another issue with owncloud.When I go into this directory /var/www/owncloud/config/config.php and I set those :
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ => [
‘host’ => ‘localhost’,
‘port’ => 6379,
‘timeout’ => 0,
‘dbindex’ => 0,
],
it shows this.How can I solve this?