Reducing cron verbosity in 10.3.0

Steps to reproduce

  1. create cronjob php -f /home/www/owncloud/occ system:cron
  2. cronjob gets executed
  3. my server sends me an email if there is any output from the configured cronjobs, here:
    1 [->--------------------------]
    2 [–>-------------------------]
    3 [—>------------------------]
    4 [---->-----------------------]
    5 [----->----------------------]
    6 [------>---------------------]
    7 [------->--------------------]
    8 [-------->-------------------]
    9 [--------->------------------]

Expected behaviour

I’d like to decrease the verbosity of the cronjob (suppress none-errors) without disabling email notifications of the oc-cronjob altogether.
I upgraded from 10.0.20 to 10.3.0, somewhere in between the cron-handling changed (before, I just called on cron.php) and the verbosity was increased.

Server configuration

ownCloud version: 10.3.0
Updated from an older ownCloud or fresh install: updated
Where did you install ownCloud from: manually/tar

Hi @owncloudomane1,
The issue is that there is too much output generated. An issue for this has already been generated in Github and it is merged and fixed for the next minor release 10.3.1:

Unfortunately I don’t know a workaround how to disable this email as of yet.
I have tried discarding all output by redirecting it to /dev/null however it doesn’t seem to work.
Perhaps somebody else has an idea.

1 Like

I added this to the cronjob:
>/dev/null 2>&1
as it was suggested here

Seems to have done the trick.

1 Like

Thanks for you replies. I should have searched the issue tracker before posting here, sorry!
I’ll disable the mail function of the oc-cronjob till the fixed version is released.