Remote into owncloud


how can I remote into my owncloud server?

If you want to visit it in a browser from any computer in the world, just visit your install path. I assume your install is very basic, so your most likely location is

Sorry for being newbie, but am having the same issue. I setup my owncloud on a Ubuntu desktop which appear to be working fine. I went into my router and config the port forwarding (port 80) to the owncloud computer, but I can't seem to access owncloud remotely.

I read up on some config file that I might have to tweak but not sue where its located or which one.

any help would be greatfully, the more details the better.


i think its nearly impossible to help here with the few details you have provided as no one in here knows your environment.

Overall making ownCloud accessible from remote is also nothing ownCloud specific as oC is just a web application served by your webserver. You would need to somehow make your webserver accessible remotely which heavily depends on your router, your network infrastructure and the webserver configuration itself.

So you might also just want to do a research on the net how to make a webserver reachable from the internet via your router. Pages like might help here. There might be also additional configuration steps needed within your webserver where the manual of this could also help.

The only ownCloud specific configuration you need to do is adding the external IP or domain to the trusted_domains setting of your config/config.php. This is probably the "config" you're referring to.

Where would you find config/config.php file on ubuntu desktop version?

This depends again on your environment and how you did the installation. But common linux tools like find or locate helps you to find such files.

If I installed apache software along with owncloud and unbutu desktop, and need internet remote access, would I be fixing apache software or ubuntu software?

Then it's most likely in /var/www/owncloud or /var/www/html/owncloud.

If you try to access from outside, you can check your webserver access logfile (/var/log/apache/access.log). If there is no entry at all, either your webserver is not started (sudo service apache start), it is not listening at port 80 or only listening to (sudo netstat -tulpen), or your port forwarding is not working correctly.

Just a quick note, I don't remember if I got back to you. It turn out that my internet provider block the port. All I had to do was to call them up and ask for the port to unblock.

Thanks again for your help.

1 Like