Remove index.php from the URL

9.1.x
help

#1

I have upgraded OwnCloud from version 9.0 for 9.1, but now I have "index.php" appearing on the URL. All files shared before the upgrade have URL like "http://cloud.mydomain.com.br/s/FHL6jCLquJzp7dj#pdfviewer" and now they are "Not found". If I add the "index.php" on the URL, like "http://cloud.companhiaduarte.com.br/index.php/s/FHL6jCLquJzp7dj#pdfviewer" I can reach the file normally.

I have checked the .htaccess and confip.php files and "RewriteBase" rules looks like OK

.htaccess

  • RewriteBase /

config.php

  • 'htaccess.RewriteBase' => '/',

#2

Hi,

have a look at the FAQ here:

giving some pointers. A request to document this within the oC docs is open since some time here:

Contributions to that are welcome.


#3

Hi RealRancor!

overwrite.cli.url is set properly... my OwnCloud is accessed by http://cloud.mydomain.com.br
and 'htaccess.RewriteBase' => '/',

I already ran sudo -u apache php occ maintenance:update:htaccess with success


#4

Then it should work and add the correct RewriteBase to your .htaccess file


#5

Thanks... nothing is wrong with OwnCloud at all... my fault... I found the error on vhost conf file
Sorry


#6

Hi @altairm could you tell me what did you do?
I'm facing the same problem.


#7

Just read the last reply here:


#8

Feedback to the new documentation is also welcome:


#9

Hi @cleristononline... I've found that I did a mistake on the owncloud vhost file conf.
Check the Directory directive of AllowOverride .... this was the cause of problem
Check below what I'm telling you and where I corrected my file


Options +FollowSymLinks
AllowOverride All

<IfModule mod_dav.c>
  Dav off
</IfModule>


#10

Thank you very much @altairm for sharing.
I followed the same way you've done. It's working now.
My server is a CentOS 7 with apache (default) and AllowOverride comes with none, I've changed to All and add the part about Dav off. NOW it's working.
Thanks again.


#11

HI @cleristononline. I'm happy for help you with my problem :slight_smile:


#12

AllowOverride All

is a general requirement that the .htaccess file shipped with ownCloud is working / used.