Repository update for owncloud 10.3 is not working

Repository update for owncloud 10.3 on ubuntu server 16.04 LTS cause fault!
Fault is videoplayer is not compatibel anymore.
Why does update not disable incompatibel apps before update?
Command solved it:
name@ubuntusrv:/var/www/owncloud$ sudo -u www-data /var/www/owncloud/occ app:disable videoplayer


that’s true since it was supposed to be replaced by Media Viewer app
Though, I just downloaded the 10.3.0 archive and it doesn’t ship the Video Player app.

My thinking is that you still had the app and did an upgrade ?
I’d say you didn’t fully read the doc :slight_smile:


So I think @FKBOX has a repo configured that ships ownCloud server files. Obviously when you install the new version files, it won’t delete existing files and folders.

I’m not sure what the best upgrade process for ownCloud servers installed via package manager is. I would assume that you should take a backup of the files, remove the package (to remove the files), and reinstall the new version. I don’t think you can remove files by upgrading a package.

Thanks for the note @FKBOX
But I would recommend to revise your upgrade process, as files removed in a new version, won’t be removed from your installation (like for example cron.php in a future release).


@eneubauer Hey ! That’s true about the update from the repo, I misread. My appologies to @FKBOX if I sounded douchy. To be honest, ownCloud packages should deal with it using pre/post install scripts (updating the cron, disabling apps).


You are correct, they should, but unfortunately they don’t. The problem with these kind of things is that many people have many different expectations. And if you start changing things somebody will be angry…


That’s very true too, well I don’t use the repository anyway, I prefer and would advise anyone to use the bare hand method with the tar and to read the doc fully. That’s a bit overkill but you know what you get :slight_smile:


I use the repository update because my knowlege is very restricted. I always have problems to understand documentation, what is really meant. If I have repository it comes up with any os-update. So I never notice if the update is there. What I notice is, when synchronisation stuck. Then I have to repair and it takes me a lot of time to correct it.
The error message tell me use occ app:disable files_videoplayer and I try and I do not know why it don’t work.
name@srv: sudo -u www-data /var/www/owncloud/occ app:disable files_videoplayer - do not work name@srv:/var/www/owncloud sudo -u www-data occ app:disable files_videoplayer - do not work
name@srv:/var/www/owncloud$ sudo -u www-data /var/www/owncloud/occ app:disable files_videoplayer
Last one worked, but I don’t know why, and the result message is not files_videoplayer disabled successful it is 'owncloud is in update mode only some occ commands are available. But I tried to update again and it worked. So every update is a thriller for me.

I disagree with you. There is no such thing as a no-knowledge solution especially if you want/need to self-host something. So you will have to learn basic linux hosting knowledge. The only other solution I know of that is actually no-knowledge is to pay some kind of provider.
EDIT: Even if you decide to do a docker installation, you will have to learn all kinds of linux things

The only difference between the third and the other commands is, that it was run as root. So you need to learn the sudo command. You can only become another user (this is what you are doing when you run sudo -u $username) with it, when you already have root privileges.

Once you are root the second command should work as well (if you are in the correct folder).

Just make sure you have a snapshot or backup you can roll back to.

1 Like

That I need to it with username www-data is logic, cause it’s a web application. What I do not understand why I have to be in owncloud directory and full path to occ command otherwise command is not found. Those specials are documented nowhere and makes it to a try and error session.

The update error message promted me do post it here, so I did. My intention was not to criticize repository update, more to help people with same problem to solve.


I mistakenly thought that the main difference is the $ sign in the bash prompt indicating a change between root privileges. But I just double checked my Ubuntu server and the prompt changes to # if you have elevated rights.

Run ls -al in your ownCloud directory, and double check that the execution bit is set:

-rwxr-xr-x  1 www-data ocadmin    283 Oct 15 10:57 occ

What I do is, I have an extra script installed in /usr/local/sbin/occ which runs the occ command like so:

#! /bin/bash
cd /var/www/owncloud
sudo -u www-data php /var/www/owncloud/occ "$@"

That way I don’t have to worry about my current working directory, sudo or anything, I can just run occ. But you need to be root in order to have it in your path.

Yes, I get that, and I thank you for it :smiley:

1 Like