Required PHP extension not found : zip

Steps to reproduce
1. Open cPanel
2. Choose ownCloud
3. Install

Expected behaviour
Normal installation as before

Actual behaviour
Can't install - error message: Required PHP extension not found : zip
PHP info shows zip extension is installed

Server configuration
Current PHP version: 5.6
ownCloud version (see ownCloud admin page): Version : 9.1.4
Fresh install: Yes
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): -

google is your friend :wink:

Thank you for your answer, but my ISP installed the extension and PHP info shows that.

The solution doesn't seem be in the server side.

A missing php extension can only be a server side issue. Please make sure the correct php is used - some ISPs have multiple php versions installed .....

If I can install ok via FTP and it works fine, I think the problem is not in the server side.
Do you agree?
Thank you for the answer.

As you talk about version (and well!), here is the version installed:
Zip enabled
Zip version 1.12.5
Libzip version 0.11.2

Will be here the problem?

The message shows, that the extension / module is not correctly loaded for your webserver. So yes, this is a server side issue.

Please contact the support of your webhoster, especially as you're using cPanel. They might be able to tell you whats wrong here and how to fix it.


ownCloud would show "PHP module zip not installed." not "Required PHP extension not found : zip" so this is something cPanel specific where people in here can't help you with.

1 Like

My ISP found the problem:

The account does not have active ssh access to the server.

Thank you.

This problem should not broke the installation. Don't you think?

if your server configuration misses a necessary component owncloud can simply not work properly.

I think as long as the message is shown the module is not correctly installed or enabled. Maybe you can get some hints from a support forum of your linux distribution how to correctly install and enable that module?