[RESOLVED] Fails to start after upgrade to Ubuntu 16.04

installation
webserver_issue
help

#1

I was running oC 8.2.5 on Ubuntu 12.04 with no issues. I just upgraded the server to Ubuntu 16.04 and I get this error message:

Internal Server Error
The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

The log gives me this as an entry:

{"reqId":"Z\/CsqYO2jERYHdNFs6o1","remoteAddr":"73.149.23.171","app":"core","message":"Exception: {\"Exception\":\"Doctrine\\\\DBAL\\\\DBALException\",\"Message\":\"Failed to connect to the database: An exception occured in driver: could not find driver\",\"Code\":0,\"Trace\":\"#0 \\\/var\\\/www\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Connection.php(973): OC\\\\DB\\\\Connection->connect()\\n#1 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/db\\\/connection.php(203): Doctrine\\\\DBAL\\\\Connection->executeUpdate('PRAGMA read_unc...', Array, Array)\\n#2 \\\/var\\\/www\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Connection.php(621): OC\\\\DB\\\\Connection->executeUpdate('PRAGMA read_unc...')\\n#3 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/db\\\/connection.php(135): Doctrine\\\\DBAL\\\\Connection->setTransactionIsolation(2)\\n#4 \\\/var\\\/www\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/DriverManager.php(172): OC\\\\DB\\\\Connection->__construct(Array, Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOSqlite\\\\Driver), Object(Doctrine\\\\DBAL\\\\Configuration), Object(Doctrine\\\\Common\\\\EventManager))\\n#5 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/db\\\/connectionfactory.php(116): Doctrine\\\\DBAL\\\\DriverManager::getConnection(Array, Object(Doctrine\\\\DBAL\\\\Configuration), Object(Doctrine\\\\Common\\\\EventManager))\\n#6 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/server.php(330): OC\\\\DB\\\\ConnectionFactory->getConnection('sqlite3', Array)\\n#7 \\\/var\\\/www\\\/owncloud\\\/3rdparty\\\/pimple\\\/pimple\\\/src\\\/Pimple\\\/Container.php(112): OC\\\\Server->OC\\\\{closure}(Object(OC\\\\Server))\\n#8 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/appframework\\\/utility\\\/simplecontainer.php(104): Pimple\\\\Container->offsetGet('DatabaseConnect...')\\n#9 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/server.php(765): OC\\\\AppFramework\\\\Utility\\\\SimpleContainer->query('DatabaseConnect...')\\n#10 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/db.php(42): OC\\\\Server->getDatabaseConnection()\\n#11 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/server.php(237): OC_DB::getConnection()\\n#12 \\\/var\\\/www\\\/owncloud\\\/3rdparty\\\/pimple\\\/pimple\\\/src\\\/Pimple\\\/Container.php(112): OC\\\\Server->OC\\\\{closure}(Object(OC\\\\Server))\\n#13 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/appframework\\\/utility\\\/simplecontainer.php(104): Pimple\\\\Container->offsetGet('AppConfig')\\n#14 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/server.php(704): OC\\\\AppFramework\\\\Utility\\\\SimpleContainer->query('AppConfig')\\n#15 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/util.php(410): OC\\\\Server->getAppConfig()\\n#16 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/util.php(343): OC_Util::loadVersion()\\n#17 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/defaults.php(52): OC_Util::getVersion()\\n#18 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/template.php(81): OC_Defaults->__construct()\\n#19 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/template.php(328): OC_Template->__construct('', 'exception', 'error', false)\\n#20 \\\/var\\\/www\\\/owncloud\\\/index.php(55): OC_Template::printExceptionErrorPage(Object(Doctrine\\\\DBAL\\\\DBALException))\\n#21 {main}\",\"File\":\"\\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/db\\\/connection.php\",\"Line\":52}","level":3,"time":"2016-08-03T22:31:21+00:00","method":"GET","url":"\/owncloud\/"}

This is a manual install of oC.

Server configuration
Operating system: Ubuntu 16.04.1
Web server: apache2
Database: sqlite3
PHP version: 7.0
ownCloud version (see ownCloud admin page): 8.2.5
Updated from an older ownCloud or fresh install: from older

Thank you in advance.
Nick


#2

Driver not found

Did you install php7.0-sqlite3?


#3

Thanks! I just did. Still not working: Now this is the log:

{"reqId":"4R0neexzv3jXrz+oh4AP","remoteAddr":"73.149.23.171","app":"core","message":"Memcache \\OC\\Memcache\\APC not available for local cache Is the matching PHP module installed and enabled?","level":3,"time":"2016-08-03T23:29:24+00:00","method":"GET","url":"\/owncloud\/"}
{"reqId":"4R0neexzv3jXrz+oh4AP","remoteAddr":"73.149.23.171","app":"core","message":"Exception: {\"Exception\":\"OC\\\\HintException\",\"Message\":\"Memcache \\\\OC\\\\Memcache\\\\APC not available for local cache\",\"Code\":0,\"Trace\":\"#0 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/server.php(269): OC\\\\Memcache\\\\Factory->__construct('39997c0b97ad8d6...', Object(OC\\\\Log), '\\\\\\\\OC\\\\\\\\Memcache\\\\\\\\AP...', '\\\\\\\\OC\\\\\\\\Memcache\\\\\\\\AP...', NULL)\\n#1 \\\/var\\\/www\\\/owncloud\\\/3rdparty\\\/pimple\\\/pimple\\\/src\\\/Pimple\\\/Container.php(112): OC\\\\Server->OC\\\\{closure}(Object(OC\\\\Server))\\n#2 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/appframework\\\/utility\\\/simplecontainer.php(104): Pimple\\\\Container->offsetGet('MemCacheFactory')\\n#3 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/server.php(756): OC\\\\AppFramework\\\\Utility\\\\SimpleContainer->query('MemCacheFactory')\\n#4 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/server.php(244): OC\\\\Server->getMemCacheFactory()\\n#5 \\\/var\\\/www\\\/owncloud\\\/3rdparty\\\/pimple\\\/pimple\\\/src\\\/Pimple\\\/Container.php(112): OC\\\\Server->OC\\\\{closure}(Object(OC\\\\Server))\\n#6 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/appframework\\\/utility\\\/simplecontainer.php(104): Pimple\\\\Container->offsetGet('URLGenerator')\\n#7 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/server.php(729): OC\\\\AppFramework\\\\Utility\\\\SimpleContainer->query('URLGenerator')\\n#8 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/helper.php(174): OC\\\\Server->getURLGenerator()\\n#9 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/template\\\/functions.php(169): OC_Helper::imagePath('', 'favicon.png')\\n#10 \\\/var\\\/www\\\/owncloud\\\/core\\\/templates\\\/layout.guest.php(15): image_path('', 'favicon.png')\\n#11 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/template\\\/base.php(160): include('\\\/var\\\/www\\\/ownclo...')\\n#12 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/template\\\/base.php(138): OC\\\\Template\\\\Base->load('\\\/var\\\/www\\\/ownclo...')\\n#13 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/template.php(211): OC\\\\Template\\\\Base->fetchPage()\\n#14 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/template.php(233): OC_Template->fetchPage()\\n#15 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/template\\\/base.php(121): OC_Template->fetchPage()\\n#16 \\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/template.php(308): OC\\\\Template\\\\Base->printPage()\\n#17 \\\/var\\\/www\\\/owncloud\\\/index.php(49): OC_Template::printErrorPage('Memcache \\\\\\\\OC\\\\\\\\Me...', 'Is the matching...')\\n#18 {main}\",\"File\":\"\\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/memcache\\\/factory.php\",\"Line\":94}","level":3,"time":"2016-08-03T23:29:24+00:00","method":"GET","url":"\/owncloud\/"}

#4

You tried to install apcu. Did you just add this to the config-file? Did you install the apcu-packet as well? Should be something like php7.0-apcu ... (you can search for packages apt-cache search php7.0 to get everything related to php7.0)


#5

Yes, I tried (the package is php-apcu). Restarted apache, but still not working. Do I need to edit the config file in some way? oC used to work, so the config file might be already set to go...

Thanks VERY much for your help.


#6

You also need php-apcu-bc


#7

Thanks, that did it! All seems to work now. Thanks very much for all your help. This is a great community.