Restored versions are not synced

all_versions
help

#1

Hi everyone,

I'm using oC 9.1.2 from the latest, official Docker Image.
As a Desktop client, I'm using 2.2.4 on Ubuntu Linux 16.10 from the official source site (http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/Ubuntu_16.10/).

Somehow I managed to zero the content for some of my files in my oC folder. On the server and on my Desktop these files were empty. I then had a look at my stored versions in the Web GUI of oC and restored the latest version for those files.
In the Web GUI I then saw that those files had their old content again. I also can download them from the Web GUI and their content looks OK again.
I did that over one hour ago now and the files on my Desktop are still empty. I restarted my oC-Client twice - the restored versions are not synced.

When I do the following, they are synced:

  1. Delete the file, either locally or in the Web GUI and wait for this deletion to be synced (file vanishes on the other side, too).
  2. Restore the file from the trash bin in the Web GUI.

Then the file restored from the trash bin is synced and has the content restored from the version restore.
But this is a huge PITA when one has many of these files. Also, it is not very confidence-inspiring to see that one cannot rely on having a complete sync locally. Also, in environments which are quite filled to the brim, one has to trust the deleted file to not be deleted permanently from the Trash bin, also.

Steps to reproduce
1. Create a new file with content.
2. Have it synced.
3. Change the content.
4. Have it synced, also.
5. Restore the version with the previous content in the Web GUI.
6. Confirm the file remains with the content of step 3 on the sync client, running on Ubuntu Linux 16.10 at version 2.2.4

Expected behaviour
The file content should become the same on the Ubuntu Client, than it has on the remote server at every time.

Actual behaviour
The client doesn't sync files which were restored from a previous version of that file.

Client configuration
Client version: 2.2.4
Client operating system: Ubuntu Linux 16.10

Server configuration
Operating system: Arch Linux running oC from the official Docker Image (https://hub.docker.com/_/owncloud/), which is Debian 8.6
Web server: Apache/2.4.10
Database: MariaDB 10.1.19
PHP version: 5.6.28
ownCloud version (see ownCloud admin page): 9.1.2
Updated from an older ownCloud or fresh install: %
Special configurations (external storage, external authentication, reverse proxy, server-side-encryption): behind nginx reverse proxy


#2

Thanks for reporting this @Judge!

I'm trying to reproduce this condition by following some equivalent steps; tell me if I'm doing it right:

  1. Creating a new text file on the web UI: new.txt
  2. Syncing it with my desktop client
  3. Edit the file and zero its content by deleting the whole text I wrote via the web UI
  4. See that the file is synced in the server with 0 bytes
  5. Go to Details > Versions for that file and restore the previous revision of the file
  6. In the local sync folder, the file contents are restored after a relatively-small time span

However, and to avoid this wait, as I'm in version 2.3.0 of the sync client (you can try already this from: https://owncloud.org/install/#testing-development) I also tried using the Force sync now button in the account view that forces the changes to be pulled from the server to my local sync folder.

If what bother's you is manually clicking Restore for every deleted file in the web UI, can try the global shortcut, selecting all and using the global restore:

So I'm so far not being successful to reproduce your problem. If I'm missing some step or some detail that could be the one causing the files not to be automatically restored. Point me to it and I'll look further into it.


#3

I tried as well and could not reconstruct the behavior.

Is the file on the server stored on a special external storage? Or is it a normal ownCloud file storage?


#4

To get the client to re-download everything, you can delete the .csync_journal.db file.


#5

Hi everyone,

thank you all for your effort and sorry that I'm answering this late. I tried to reproduce the issue with a fresh setup and couldn't. With a freshly installed OC server everything works.
For my production Data, I indeed had to delete the .csync_journal.db file, as guruz suggested, to force a re-sync for everything.

I don't know why, maybe this is because of the large amount of files I have. Never mind - since I cannot reproduce this on myself anymore, please consider this one solved.

Thanks again for everyones help!