Reverse proxy problems in config file older version 8.1


#1

Hello - I am having a hard time connecting with a reverse proxy from an apache2 server to an owncloud 8.1 instance on server 2008. I realize this is unsupported now, but am hoping to get another year out of this platform while I build a new one. Can anyone take a look, especially at this line, which I cant seem to figure out:

‘overwritecondaddr’ => ‘^192\.168\.2\.79$’,

The manual says it needs to be:
" The value must be a regular expression of the IP addresses of the proxy. This is useful when you use a reverse SSL proxy only for https access and you want to use the automatic detection for http access."
https://doc.owncloud.org/server/8.2/admin_manual/configuration_server/reverse_proxy_configuration.html

any help greatly appreciated - I can get to the door and see the owncloud login but it is greyed out and cant login

<?php $CONFIG = array ( 'instanceid' => 'oc62q5kt2xq6', 'passwordsalt' => 'vxy0J4uQOORt7HqT0n0DvwWF5WP/Pk', 'secret' => 'hyujCINkbMghOIw0ocrr3gcS6uR3zmnkPCL.LuoUAN0mqDOy', 'trusted_domains' => array ( 0 => '127.0.0.1', 1 => 'pet310', 2 => '68.118.47.66', 3 => 'pet310.belldesign.com', 4 => 'bdcloud.belldesigncloud.com', 5 => 'www.bdcloud.belldesigncloud.com', 6 => '192.168.2.201', 7 => '192.168.2.79', 8 => 'belldesign.com', ), 'datadirectory' => 'D:\\owncloud', 'dbtype' => 'mysql', 'version' => '8.0.2.0', 'installed' => true, 'forcessl' => true, 'mail_smtpmode' => 'smtp', 'mail_smtphost' => 'smtp.belldesign.com', 'mail_smtpport' => '25', 'mail_from_address' => 'owncloud', 'mail_domain' => 'belldesign.com', 'mail_smtpauth' => 1, 'mail_smtpauthtype' => 'LOGIN', 'mail_smtpname' => 'owncloud@belldesign.com', 'mail_smtppassword' => 'deadfred1', 'overwrite.cli.url' => 'https://www.bdcloud.belldesigncloud.com', 'htaccess.RewriteBase' => '/', 'dbname' => 'owncloud', 'dbhost' => 'localhost', 'dbtableprefix' => 'oc_', 'dbuser' => 'owncloud', 'dbpassword' => 'owncloud', 'loglevel' => 3, 'trusted_proxies' => array ( 0 => '192.168.2.79', 1 => 'belldesigncloud.com', 2 => 'www.belldesigncloud.com', ), 'overwritehost' => 'belldesigncloud.com:443', 'overwriteprotocol' => 'https', 'overwritewebroot' => 'bdcloud.belldesigncloud.com', 'overwritecondaddr' => '^192\\.168\\.2\\.79$', );

#2

This is from my owncloud.config file in appPools:

  <sites>
        <site name="owncloud" id="1" serverAutoStart="true">
            <application path="/" applicationPool="owncloud">
                <virtualDirectory path="/" physicalPath="C:\inetpub\wwwroot\owncloud" />
            </application>
            <bindings>
                <binding protocol="http" bindingInformation="*:80:www.bdcloud.belldesigncloud.com" />
                <binding protocol="net.tcp" bindingInformation="808:*" />
                <binding protocol="net.pipe" bindingInformation="*" />
                <binding protocol="net.msmq" bindingInformation="localhost" />
                <binding protocol="msmq.formatname" bindingInformation="localhost" />
            </bindings>
        </site>
        <siteDefaults>
            <logFile logFormat="W3C" directory="%SystemDrive%\inetpub\logs\LogFiles" />
            <traceFailedRequestsLogging directory="%SystemDrive%\inetpub\logs\FailedReqLogFiles" />
        </siteDefaults>
        <applicationDefaults applicationPool="DefaultAppPool" />
        <virtualDirectoryDefaults allowSubDirConfig="true" />
    </sites>

</system.applicationHost>

<system.webServer>

    <asp>
        <cache diskTemplateCacheDirectory="%SystemDrive%\inetpub\temp\ASP Compiled Templates" />
    </asp>

    <caching enabled="true" enableKernelCache="true">
    </caching>

    <cgi timeout="00:30:00" />

    <defaultDocument enabled="true">
        <files>
            <add value="index.php" />
            <add value="Default.htm" />
            <add value="Default.asp" />
            <add value="index.htm" />
            <add value="index.html" />
            <add value="iisstart.htm" />
            <add value="default.aspx" />
        </files>
    </defaultDocument>

#3

Hey,

it seems your version is even older then the assumed 8.1 in your topic title.

Maybe your issue could be related to a bug in this older version or similar?

Or it could be also possible that the chosen Windows platform (from what i had read in the past ownCloud isn’t running on Windows anymore since quite some time) isn’t supporting such a setup at all?

It could be also easily possible that the issue is not related to the reverse proxy setup at all and there is just something else blocking the login?


#4

It was that I used just an A name and it needed a CNAME! I had assumed the worst as well, but I have to say that owncloud 8 has ran like a champ for 3 years straight on IIS 7.5 with hardly a hiccup. Of course I have another one running on a Univention host now for the time this halts! Thanks for looking at it