Running the installation wizard


#1

Hi,

I just installed Ubuntu server 16.04 and followed these instructions: https://doc.owncloud.org/server/latest/admin_manual/installation/source_installation.html#ubuntu-installation-label

From Install the Required Packages On Ubuntu 16.04 LTS Server
And then the instructions under Install ownCloud

I am at the step: Run the Installation Wizard

So no problem there the page opens and I can fill the fields.

When I click "Finish setup" I get an Access Denied error

Am I missing something?

I'm not sure what exactly I am supposed to input in here.
Seems like this page is for creating a DB admin.

But under "Configure the database" Am I creating a DB or connecting to an existing one?

I did not see any instructions telling me I needed to create a DB.

Thank you


#2

How did you configure your database? Did you use"create a DB"? or did you use it on a separate host?
Which user should be used for database access?
It can be that there is an issue, because mariadb/ mysql has improved their security and and root is only allowed to be used for localhost.

We need some more information about your setup....


#3

I just followed the instructions. There are no step for creating/configuring a DB in your instructions. So I presumed that it gets created from the installation wizard page.

https://doc.owncloud.org/server/latest/admin_manual/installation/source_installation.html#ubuntu-installation-label


#4

You can find it under installation wizard.


#5

Where? That page tells me to input an admin username and password and then Click “Finish Setup”. Exactly what I did. It does not tell me to create or configure a DB. It does not even say we need or not need to create one before.

Point your web browser to http://localhost/owncloud
Enter your desired administrator’s username and password.
Click “Finish Setup”.


#6

Does this part doesn't describe the database part for MySQL/MariaDB?

MYSQL/MariaDB

MariaDB is the ownCloud recommended database. It may be used with either ownCloud Server or ownCloud Enterprise editions. To install the recommended MySQL/MariaDB database, use the following command:

sudo apt-get install mariadb-server

If you have an administrator login that has permissions to create and modify databases, you may choose “Storage & Database”. Then, enter your database administrator username and password, and the name you want for your ownCloud database. Alternatively, you can use these steps to create a temporary database administrator account.

sudo mysql --user=root mysql
CREATE USER 'dbadmin'@'localhost' IDENTIFIED BY 'Apassword';
GRANT ALL PRIVILEGES ON . TO 'dbadmin'@'localhost' WITH GRANT OPTION;
FLUSH PRIVILEGES;
exit

For more detailed information, see MySQL/MariaDB.

You can choose your database. But all is described in our installation instruction. You can choose another database, too.


#7

Thanks I'll try this.

Just to be clear.

What would be the official steps when starting from scratch?

What I think are the steps:
1. Install Ubuntu 16.04 server
2. Install the required and recommended modules
3. Install ownCloud
4. Configure Apache Web Server
5. Do additional Apache Configurations
6. Enable SSL
* 7. Create a MariaDB Database ? (is that it?)
8. Run the Installation Wizard
9. Set Strong Directory Permissions


#8

I am having trouble when I try this line after creating the dbadmin user.

GRANT ALL PRIVILEGES ON . TO 'dbadmin'@'localhost' WITH GRANT OPTION;

It says "You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'TO 'dbadmin'@'localhost' WITH GRANT OPTION' at line 1"


#9

I was able to manage to make it work by doing some MySql googling.

I created the dbadmin user like so: CREATE USER 'dbadmin'@'localhost' IDENTIFIED BY '123456';
then I created a DB: CREATE DATABASE owncloud;
then I exited mysql
then I gave dbadmin access to the DB: mysql -h localhost -u dbadmin -p owncloud
then I input these credentials in the web Installation Wizard and created a user named ocadmin

And this time it worked.