S3 connectivity


I have an S3 compatible provider which I would like to use as primary storage for owncloud.
I can connect it using External storage (files_external_s3 app), and I use it to find the correct configuration, but not I’ve found it, I would like to use the same parameters for primary storage.

Unfortunately, it doesn’t work, or, more likely, I don’t know how to set it right.
Here is the config that works:

How should the config.php file look like ? I know I have to use this link, but no luck now ?

Thanks for your help !

This is the wrong link. It is pointing to the documentation for setting up S3 as primary storage.
This is the correct link.

Enable path style is usually not required (and is, in fact, incompatible with newer Amazon datacenters), but can be used with non-Amazon servers where the DNS infrastructure cannot be controlled. Ordinarily, requests will be made with http://bucket.hostname.domain/ , but with path style enabled, requests are made with http://hostname.domain/bucket instead.

Perhaps try disabling path style?
Also if you still have no luck, please check the ownCloud log.

Finally you neglected to fill out the post template, it will greatly help in the forum users being able to help you. Here it is again:

Steps to reproduce

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:

Web server:


PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration


Operating system:


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

I really think you misunderstood what I really try to do : I want to set up S3 storage as primary storage. I use external storage extension to find the correct settings for my S3 backend, and I found it, as shown in the picture (green circle).

Whant I want to do, is to use this settings in config.php

Ah sorry, files_external_s3 is only for external storage configuration.
If you want to use S3 as primary storage you need to use files_primary_s3:


So disable the other app, and install this one. Then you should be able to access S3 using one of the configurations from the documentation:

Please provide the information from the post template like a config report, then we can tell for sure which app you have installed.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.