Scan to OwnCloud with Samsung Copier

help

#1

since today we had a copier which could send scans to a WebDAV account.
No problem with OwnCloud.
We have a special account named "scan" to which all Files can be uploaded. Everyone who whishes to, can get files in this account as a share.

Now we have a new copier which cannot upload to WebDAV but only to SMB or FTP.
I have not succeeded in setting up the same service again with this new machine.

Server configuration
it's a QNAP Station TS-212P V4.2.2
Operating system:Linux 3.4.6 #1 Thu Sep 1 10:42:02 CST 2016 armv5tel unknown
Web server: Apache/2.2.31 (Unix)
Database: Ver 5.5.44-MariaDB-log for Linux
PHP 5.5.36
ownCloud version (see ownCloud admin page):ownCloud 8.0.4 (stable)

Updated from an older ownCloud or fresh install:fresh install
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):none

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.
results in showing the Files ...

#2

Hi,

there is a FAQ explaining the possible ways to add files from external systems to ownCloud available here:


#3

Hi again,

after some weeks of high workload I must get back to this issue again.

The FAQ (which I thoroughly studied previeous to issuing this post) gives no solution that works for me.

The Machine does not speak WebDAV.
Creating an external Directory for upload and using "External storage support" does not work either, because the upload-dir must be shared between multiple users.

I still don't see a solution

thanks
m.


#4

Why can't you use a folder between different users? Can't you manage your group settings in a way that it works? In Linux you could use ACLs which offer a very detailed permission settings.

By the way, OC 8.0 is not supported any more and the version you are using is very old. Some QNAP system don't support OC 9.0 or newer.