Security & setup warnings

I got this warning ,

Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking

How can I fix this ?

Oh, if only there were some kind of help/hint/link near this message that could help you…



tried that…
Then this happend

that’s pretty ambiguous.

What did you tried and how?

I doubt that you got this error message by just clicking on the link.

I followed this link

and did try too download redis.

Didn’t really understand that much

then maybe the appliance would be better for you.

The appliance comes preconfigured, so you don’t need to download packages or change settings. It just works.

But the problem is owncloud is already running do I need to delete ? or can I keep it and use applicance ?

I am not familiar with your environment. If you end up using the appliance instead of your current ownCloud installation then I would delete the current ownCloud installation. If you have made some important changes to your current ownCloud installation or have users/data on it - I would not delete it before performing a backup.

I have already come so far, have only a few steps left so I think I will learn and try out
if you have a solution or any video I can see or try, will help a lot

1 Like

After installing Redis
then I used this configuration in my config.

‘filelocking.enabled’ => ‘true’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ => array(
‘host’ => ‘localhost’,
‘port’ => 6379,
‘timeout’ => 0.0,
), :slight_smile: everything works now!

1 Like