Server error 503 and others related to encryption


#1

Using 10.0.7 on Open SuSE LEAP 42.3.

I turned off encryption an decrypted the whole site (took several hours), seems to have worked, no error messages.

Then I disabled the encryption app.

The pdf-reader app is active.

When I click on a pdf document (which is no longer encrypted), I get 503 and log says "no encryption module active" or the like. Then I reactivated the encryption app. Now I get a different error: Private key not found.

When I de-activate the pdf-reader app, I can download the pdf file without problems.

Any ideas?

Regards
Stefan


#2

Some more info: On the new server, Encryption is turned off, and before moving data + mariadb to the new server, all files on the old server were decrypted.

No sync with the new server always throws 503 and says:

26.02.2018 17:46:06, ownCloud,Server hat "503 Service Unavailable" auf "PUT xxx.ods" geantwortet (Encryption not ready: Tried to access encrypted file but encryption is not enabled)

Would it help to turn on encryption on the new server and then start the decryption process?

Where is the information kept that a file is encrypted (in fact it is not, I can copy it from the data folder manually and open it without problems with OpenOffice.

Thanks in advance,
Stefan


#3

Hi,

here are the steps you could try:

a) try to enable encryption app
b) enable masterkey
c) run occ command : ./occ encryption:encrypt-all
d) try to run decrypt command: ./occ encryption:decrypt-all
e) Copy the data from data folder to else where
f) And then try to create new ownCloud instance and add files there.

credit goes to @sharidasan


#4

Thank you. Finally, we started from scratch with a new cloud setup.
Regards
Stefan B.