Server Permission Issues, once again


#1

Deployed owncloud 10 on ubuntu 18

Changed data file to a different location

I get an “you don’t have permission to create or upload files here”

The New data file location has 777 www-data:www-data permission to main directory and all subdirectories and files. Yes I know 777 is too much but I tried all I could think before posting

Any suggestion, Im completely out of ideas after 6 hours of this…


#2

it should be www-data:www-data recursive


#3

Make sure the config.php has the location you want for the data folder. You might be changing the permissions on a folder that isn’t being used, and the data is being placed in another location


#4

Yes, sorry, typo when writting here it is www-data:www-data in the server


#5

It is, it goes to the new location


#6

Hi,

please read the documentation

https://doc.owncloud.com/server/10.0/admin_manual/installation/system_requirements.html


#7

Sorted.
The script did not work, it threw quite some errors.

In the end what I did was:

Uninstall Owncloud
Delete all owncloud files
Delete Database

Create Database and user
Reinstall Owncloud
Move Data directory to desired location
assign www-data:www-data to Data directory in new location
Run installation wizard

Evoilá


#8

Fresh install is always the cleanest solution :slight_smile:
great that it worked for you