"Server replied \"403 Forbidden\" to \"PUT https://www.example.com.au/owncloud/remote.php/dav/files/Administrator/DIRECTORY/THINKB.mdb\"


#1

Steps to reproduce

  1. Deploy OwnCloud via Softaculous Apps Installer in cPanel
  2. Install Windows Client on Win10 64
  3. Synchronize chosen directories

Expected behaviour

All files within directory should upload to cloud.

Actual behaviour

Majority of files upload and are accessible via web browser immediately. Specific file extensions however, ie: *.mdb are not uploading and report the following: Server Replied “403 Forbidden” to “PUT https://URL/FILE.mdb

Server configuration

Operating system: Centos Enterprise OS

PHP version: 5.4.45

ownCloud version: 10.0.0.8

Updated from an older ownCloud or fresh install: Fresh Install

Where did you install ownCloud from: Softaculous App Installer within cPanel

Below is an excerpt from the Client Log in Windows for 1 file that was to be uploaded:

05-31 12:22:25:696 [ warning sync.networkjob ]: QNetworkReply::NetworkError(ContentOperationNotPermittedError) “Server replied “403 Forbidden” to “PUT https://www.example.com.au/owncloud/remote.php/dav/files/Administrator/DIRECTORY/THINKB.mdb”” QVariant(int, 403)
05-31 12:22:25:697 [ info sync.networkjob.put ]: PUT of “https://www.example.com.au/owncloud/remote.php/dav/files/Administrator/DIRECTORY/THINKB.mdb” FINISHED WITH STATUS QNetworkReply::NetworkError(ContentOperationNotPermittedError) “Server replied “403 Forbidden” to “PUT https://www.example.com.au/owncloud/remote.php/dav/files/Administrator/DIRECTORY/THINKB.mdb”” QVariant(int, 403) QVariant(QString, “Forbidden”)
05-31 12:22:25:699 [ warning sync.propagator ]: Probably firewall error: 403 , blacklisting up to 1h only
05-31 12:22:25:701 [ info sync.database ]: Setting blacklist entry for “DIRECTORY/THINKB.mdb” 21 “Server replied “403 Forbidden” to “PUT https://www.example.com.au/owncloud/remote.php/dav/files/Administrator/DIRECTORY/THINKB.mdb”” 1527733345 3600 1414708617 “” “” 0
05-31 12:22:25:702 [ info sync.propagator ]: blacklisting “DIRECTORY/THINKB.mdb” for 3600 , retry count 21
05-31 12:22:25:703 [ warning sync.propagator ]: Could not complete propagation of “DIRECTORY/THINKB.mdb” by OCC::PropagateUploadFileV1(0xd8a4110) with status 9 and error: “Server replied “403 Forbidden” to “PUT https://www.example.com.au/owncloud/remote.php/dav/files/DIRECTORY/THINKB.mdb””

As far as I can see these *mdb files are the only ones in the several thousand files I have that are not being uploaded.

If anyone can recommend suggestions or solutions it would be appreciated.

Thank you for your time.

Alex


#2

Hey, i don’t have that much knowledge about such topics but the “403 Forbidden” in connection with the “*mdb files are the only ones in the several thousand files” leads me to the assumption that there might be some security module or some configuration on your web server blocking those files to get uploaded to ownCloud.