Server replied:internal Server Error


#1

I have installed a fresh copy of Owncloud due to all the issues I had after attempting to upgrade from 8.1. During install created MYSQL database due to suggested in Owncloud support page. 1 device has about 350 GB a data I am attempting to sync - worked fine on 8.1. Now I get the error listed in the topic at 200 GB now. The last time it was 165 GB before rebuild again. The articles continue to say it is a permission issue but it seems like a bug in owncloud ver 10. I have now spent about 40 hrs of time just trying to do a simple upgrade from 8.1 and still have issues with the install. Can someone tell me how to resolve this issue or if it is a bug that cannot be resolved now!!!

Steps to reproduce

  1. Start Sync process from client and wait

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system: Ubuntu 18.04 LTS

Web server: Apache2

Database: MYSQL

PHP version:

ownCloud version: 10.0.0.8

**Updated from an older ownCloud or fresh install:**Fresh Install

Where did you install ownCloud from: Repository per your article

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

The cause of the internal server error is usually mentioned in the owncloud.log. Unfortunately you omitted that part. So its now up to us to spend an amount of time with guessing. :wink:


#3

Hey,

i think depending on the typo of the problem an internal server error could also end up in the web server log (which was omitted as well) without even reaching the owncloud.log.


#4

Well, I will say that the log has nothing usable in it that I found. Maybe you can find something. It only says “the computed checksum does not match the one received from the client”. This is a fully rebuilt server, owncloud fresh install, brand new sync setup. This seems to be a failure within the owncloud system. The folder is large (about 80 GB) but not one file is larger than about 100 MB.

Here is the section from the log that is applicable since I can’t upload the entire log.
08T07:21:00+00:00",“remoteAddr”:“50.248.196.1”,“user”:“maring”,“app”:“webdav”,“method”:“PUT”,“url”:"/owncloud/remote.php/dav/files/maring/DrMaring/NetBakData/administrator@SERVER/Disk%20D/Shares/Dolphin/Working/2437802.V51",“message”:“Exception: {“Message”:“HTTP\/1.1 400 The computed checksum does not match the one received from the client.”,“Exception”:“Sabre\\DAV\\Exception\\BadRequest”,“Code”:0,“Trace”:”#0 \/var\/www\/html\/owncloud\/apps\/dav\/lib\/Connector\/Sabre\/Directory.php(172): OCA\\DAV\\Connector\\Sabre\\File->put(Resource id #65)\n#1 \/var\/www\/html\/owncloud\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(1095): OCA\\DAV\\Connector\\Sabre\\Directory->createFile(‘2437802.V51’, Resource id #65)\n#2 \/var\/www\/html\/owncloud\/lib\/composer\/sabre\/dav\/lib\/DAV\/CorePlugin.php(525): Sabre\\DAV\\Server->createFile(‘files\/maring\/Dr…’, Resource id #65, NULL)\n#3 [internal function]: Sabre\\DAV\\CorePlugin->httpPut(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#4 \/var\/www\/html\/owncloud\/lib\/composer\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#5 \/var\/www\/html\/owncloud\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(479): Sabre\\Event\\EventEmitter->emit(‘method:PUT’, Array)\n#6 \/var\/www\/html\/owncloud\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(254): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#7 \/var\/www\/html\/owncloud\/apps\/dav\/lib\/Server.php(278): Sabre\\DAV\\Server->exec()\n#8 \/var\/www\/html\/owncloud\/apps\/dav\/appinfo\/v2\/remote.php(31): OCA\\DAV\\Server->exec()\n#9 \/var\/www\/html\/owncloud\/remote.php(165): require_once(’\/var\/www\/html\/o…’)\n#10 {main}",“File”:"\/var\/www\/html\/owncloud\/apps\/dav\/lib\/Connector\/Sabre\/File.php",“Line”:172,“User”:“maring”}"}
{“reqId”:“9e17ce77-b39e-4b3d-9b7c-8017ef283bda”,“level”:4,“time”:“2019-02-08T07:21:00+00:00”,“remoteAddr”:“50.248.196.1”,“user”:“maring”,“app”:“webdav”,“method”:“PUT”,“url”:"/owncloud/remote.php/dav/files/maring/DrMaring/NetBakData/administrator@SERVER/Disk%20D/Shares/Dolphin/Working/2437900.I51",“message”:“Exception: {“Message”:“HTTP\/1.1 400 The computed checksum does not match the one received from the client.”,“Exception”:“Sabre\\DAV\\Exception\\BadRequest”,“Code”:0,“Trace”:”#0 \/var\/www\/html\/owncloud\/apps\/dav\/lib\/Connector\/Sabre\/Directory.php(172): OCA\\DAV\\Connector\\Sabre\\File->put(Resource id #65)\n#1 \/var\/www\/html\/owncloud\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(1095): OCA\\DAV\\Connector\\Sabre\\Directory->createFile(‘2437900.I51’, Resource id #65)\n#2 \/var\/www\/html\/owncloud\/lib\/composer\/sabre\/dav\/lib\/DAV\/CorePlugin.php(525): Sabre\\DAV\\Server->createFile(‘files\/maring\/Dr…’, Resource id #65, NULL)\n#3 [internal function]: Sabre\\DAV\\CorePlugin->httpPut(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#4 \/var\/www\/html\/owncloud\/lib\/composer\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#5 \/var\/www\/html\/owncloud\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(479): Sabre\\Event\\EventEmitter->emit(‘method:PUT’, Array)\n#6 \/var\/www\/html\/owncloud\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(254): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#7 \/var\/www\/html\/owncloud\/apps\/dav\/lib\/Server.php(278): Sabre\\DAV\\Server->exec()\n#8 \/var\/www\/html\/owncloud\/apps\/dav\/appinfo\/v2\/remote.php(31): OCA\\DAV\\Server->exec()\n#9 \/var\/www\/html\/owncloud\/remote.php(165): require_once(’\/var\/www\/html\/o…’)\n#10 {main}",“File”:"\/var\/www\/html\/owncloud\/apps\/dav\/lib\/Connector\/Sabre\/File.php",“Line”:172,“User”:“maring”}"}
{“reqId”:“5aaf354e-cb17-48b5-821d-981e2c06fe0b”,“level”:2,“time”:"2019-02-


#5

Hey,

sorry but it seems we have missed the following:

This looks to me like a quite outdated version, maybe you could update to 10.1.0 first and then try again to see if you’re not facing this issue anymore?


#6

Ok, I have now upgraded to ver 10.1.0. Still have the exact same issue with server error (server replied: Internal Server Error) on the same folder. This seems to be getting worse. So I even tried to create a new user again to ensure no “permission” issue and now in the new version, you have to add an email address. Worse yes, I cannot log into the web UI with the new user - states bad password. I reset it on the web UI while logged in as an admin, no change.


#7

Oh, I missed one important part of my findings. The folder in question says it has 44 GB in it. but on the web interface shows nothing - server has files in it. Seems to be a disconnect between storage and web UI which is most likely causing this. If you can tell me what info you need, I will post it here.


#8

One more reply. Found something new in the logs. “Message Allowed Memory Size of 168435456 bytes exhasted” Where do I change this setting at. This is new log since upgrade to 10.1


#9

I guess there is no answer for this failure at this time since no response in 7 days