Session_lifetime frustrated by other calls

expert
reported_bug
9.1.x
help

#1

I have been installing OwnCloud 9.1 and have had trouble implementing a 15 minute session time-out which is required by our security officer.

In my config.php I had
'session_lifetime' = > 900,
'session_keepalive = > false,

First I noticed that the Notifications is sending messages everything few seconds, so I disabled that app. Then I saw an Ajax message to "getstoragestats.php" repeated every 5 minutes. I have only been able to stop this by patching files.js. Doing so finally let the session_lifetime take effect.

The 'getstoragestats' call doesn't seem to be crucial to the workings of OwnCloud. Is there a way to stop this call by a parameter?
Otherwise I think the time of repetition should be longer than the session_lifetime parameter. Is there any way to influence that timing?


#2

We've been having the same issue. For compliancy we have to enforce a 10 minute session timeout but the getstoragestats.php call every 5 minutes is preventing the session from being timed out. I would prefer to disable this by setting a configuration setting instead of patching a file so that future updates won't overwrite this.


#3

Just report a bug to https://github.com/owncloud/core/issues if something doesn't work or needs to be changed within ownCloud.


#4

I've filed Issue 26077


#5

Thanks. Here the bugreport as a reference: