Set bandwidth limit using oc-client; qt-version, wondershaper

upload_limit
help

#1

Hi there,

I am using the latest owncloud client on Debian/Jessie (jessie backports) . For some strange reason that I do not want to explain right now - I had problems with synchronisation that disapeared after setting an upload limit on two Ubuntu systems in the same network - I need to limit the upload bandwidth on the debian system.

I cannot set a bandwidth limit on the debian system via GUI because the qt-version is not high enough. oc-client needs qt >= 5.4 .

Is there an other way to set a bandwidth limit?
-via command line options when starting the client?
-via settings in a config file?
-via ???

Thanks,
Martin
P.S.: I do not want to migrate the computer to debian-stretch and I want to avoid to migrate from debian to ubuntu


#2

Hi,

all available config options and command line parameters are described here:

https://doc.owncloud.org/desktop/2.2/advancedusage.html

If you can't find the option you're looking for there its unlikely that they exist.


#3

There might be two other possibilities:

  1. Recompile the client with the following compile time options: https://github.com/owncloud/client/issues/4334#issuecomment-195716659

  2. Start the client with one parallel upload: https://github.com/owncloud/client/issues/4334#issuecomment-203575600


#4

Thank you, RealRacer,

I did not try to recompile the client. (I am not a developer of software...)
I tried to shape the upload traffic with wondershaper. This helped. Nevertheless the documentation of wondershaper is a bit outdated. So I couldn't figure out how to change the configuration/setup files correctly to start the shaping at system start.

I wonder how/why the debian/owncloud developers do not do anything about this. They did a "backport" with an obvious problem.
I could imagine either a statically linked oc-client binary with the right qt-version.
Or maybe a side by side installation of two qt-versions, so that the oc-binary finds the correct one.

Martin


#5

Hello.

For this i use the apache bw mod.

Br,
Christian


#6

Thanks Christian,

I solved the problem with a "hardware downgrade". I use an 100Mbit/s usb-ethernet-adapter instead of the builtin 1GBit/s ethernet port.
This has the additional advantage for me, that this approached solves the same problem for Windows, too.

I admit that this is not a general solution, but it works perfect in this case.