Set up in Android failed

help

#1

Hello,
this was really strange when I wanted to set up the app in Adroid:
Steps to reproduce
1. start of the new downloaded app owncloud
2. typing in the server, name and passwort and click on connect

Expected behaviour
Start of the app and view of owncloud

Actual behaviour
First it proceeded in a normal way and you already saw the menu of the owncloud. Then I landed back in log in screen and should type my password again but the problem is that the user name was somehow doubled. There now stands "name@name" and with this name the log in does not function. I'm also not able to change the user name. So I cannot go further or back. I also tried with a reinstallation of the app but the same thing happened.

Mobile client configuration
Client OS (iOS, Android, ...): Andorid
Client version:7.0

Server configuration
Server configuration was done through owncube

Please help me to be able to use the app. Thanks


#2

Hi, @michael1

What version of the ownCloud Android app are you using? Where did you get if from: Google Play Store, F-Droid...?

Did you change your password?

Can you still access via web to your account with same user and password as before?


#3

Hi davivel,
I installed the ownCloud App out of the Google Play Store. It's the version 2.3.0.
I haven't changed my password and I'm still able to work in the browser.
In my opinion the reason is that the user name is not right but it was changed automatically in "name@name" and I'm not able to modify it. It's really strange.


#4

Please, try to delete your account in the device: device settings > accounts > owncloud > top right menu > remove account. Then open the app to create it again.

Did you change something recently in the server configuration, or is if fully managed by ownCube?


#5

I'm checking ownCube. Do they still provide an ownCloud server to you, or did they migrate you to a Nextcloud server?


#6

I tried it but it happend the same thing.
I haven't changed anything. It's managed fully by ownCube and it's an ownCloud server not nextcloud


#7

Now I recognised something: Even if I write the coplete link in the server field the app is automatically adding "name@" at the beginning of the server whereby also the user is automatically changed in "name@name".
I tricked the system now by just writing the server name without the user name and the @ in it. It then was completed to the correct settings and I was able to log in. Strange


#8

Are you typing something like:

https://user@example.com

into the server address field of the server? If yes this is not the way the server address field is used for. This is just the server URL like https://example.com what you need to enter there, nothing more.


#9

You were not writing the complete link? What part were you omitting?


#10

Thanks. This was the error. I haven't seen any description of this field so I thought that I have to write the whole URL address. I functioned now.