Setting email with occ doesn't show in GUI?


#1

Hi,

Using Owncloud 10, latest, installed fresh today.

I am trying to add a user through the occ utility so that I can script the addition of 100+ users.

I've done this:

export OC_PASS=test
su -s /bin/sh www-data -c '/usr/bin/php /var/www/html/owncloud/occ user:add --password-from-env --group="CCC-RW" --group="All-R" test.user\@domain.com'
su -s /bin/sh www-data -c '/usr/bin/php /var/www/html/owncloud/occ user:setting test.user\@domain.com settings email --value "test.user@domain.com"'

The email setting seems to be set okay:

root@LIN01:# su -s /bin/sh www-data -c '/usr/bin/php /var/www/html/owncloud/occ user:setting test.user\@domain.com'
  - core:
    - lang: en_GB
  - firstrunwizard:
    - show: 0
  - settings:
    - email: test.user@domain.com
    - firstrunwizard: 0

However when I log into the web interface as 'test.user@domain.com' the 'Email' box in the user settings is blank.

Am I doing something wrong?

Thanks


#2

Email addresses for users are stored in the accounts table in ownCloud 10.


#3

I checked out the documentation on this and see that the admin manual is misleading and does not include an example updated for ownCloud 10. I have filed an issue at the documentation repository to get this updated: https://github.com/owncloud/documentation/issues/3152


#4

I just implemented this onto the user:add command https://github.com/owncloud/core/pull/28122 hopefully this will make 10.0.3 or you can use the patch file https://github.com/owncloud/core/pull/28122.patch


#5

Maybe you can help review the code and feature and give your feedback on the github pull request?