Setting HSTS on a Subdomain

webserver_issue

#1

Running Owncloud on a shared hosting enviroment using FCGI. After some try all runs smooth but activating HSTS

Adding this line to my htaccess changes nothing
Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains; preload"
i tryed nearly every position to insert even if is the right position for it but nothing happens

any help very appreaciated!
thx


#2

FCGI / FastCGI is not using .htaccess files.


#3

so why are some lines interpreted and this not?


#4

Thats probably a question perfectly fitting in a support forums of your used webserver.


#5

You can restrict the setting being made via .htaccess.