Setting webdav URL

help

#1

I have an owncloud server that is dockerized. My configuration is quite simple:

Nginx server (HTTP is redirected to HTTPS) -> proxy -> owncloud docker instance

Everything is working fine. I have configure the owncloud hostname in the config.php file. Unfortunately, the WebDav link in the toolbar displays an http link, not the https.

How can I force this URL ?

Thank you, kind regards, Charles

Server configuration
Operating system: Fedora 24
Web server: Nginx (proxy)
Database: PgSQL (docker)
PHP version: php:5.6-fpm
ownCloud version (see ownCloud admin page): latest
Updated from an older ownCloud or fresh install: fresh install (docker)


#2

You can set this variable in your config/config.php:

/**
 * When generating URLs, ownCloud attempts to detect whether the server is
 * accessed via ``https`` or ``http``. However, if ownCloud is behind a proxy
 * and the proxy handles the ``https`` calls, ownCloud would not know that
 * ``ssl`` is in use, which would result in incorrect URLs being generated.
 * Valid values are ``http`` and ``https``.
 */
'overwriteprotocol' => '',

#3

Thank you very much for highlighting this option. It works perfectly.