Setup web-server, installed Owncloud, cannot see web-server

webserver_issue

#1

I set up a web-server (Apache2) in Raspbian Stretch, on a Raspberry Pi 3 B+. It worked fine in my browser by typing in the IP address (192.168.1.201) or hostname (pi201) & took me to my index.html in /var/www/html. Then I installed Owncloud in /var/www/owncloud. Now when I type in the same IP or hostname in the browser, it goes straight to Owncloud (which works fine), not my index.html in /var/www/html. I can’t even see my web-pages anymore. How can I see my web-pages again? Please help & thanks!


#2

Hey,

i think this completely depends on your web server configuration and where it is looking for the index.html. If it e.g. redirects all requests done to http://192.168.1.201 to /var/www/owncloud then the index.html in /var/www/html gets completely ignored.


#4

Hey,

i think there must be a configuration which points to /var/www/owncloud instead of /var/www/html. Without such a configuration you probably would never be able to access ownCloud installed into /var/www/owncloud.


#5

Solved it myself - no thanks to the speculative garbage!


#6

Please try to avoid (generally and not only in the scope of this thread) calling posts “garbage” which are trying to help you and which are pointing you into valid directions where to look for to solve your issue.

It would be great if you could share the solution. I guess there was a configuration file telling your web server to look at a different place?