Shared folder not visible

hosting

#1

Dear community,

one of our LDAP synced users does not see a shared folder since there was interruption of her oc client synchronisation.

We tried solving the problem by removing and readding her from the Active Directory group that syncs to owncloud. But it does not help.

A different shared folder is still visible.

When I try to share the folder for the user additionally to the group he is in, the error "The path is already shared" pops up.

Any suggestion is highly appreciated.

Best
Norman


#2

Here are some more information and screenshots to specify the situation:
The folder GKK is created and shared by the user Support. The AD group AlleGKK has permissions to read and edit.
But the user is not able to see this folder when she is a member of that group.

If the user is removed from the active directory group AlleGKK and manually get permissions to edit and share that folder it is visible again.


#3

Hi, @Scorp1337, Could you be more specific in the ownCloud version, are there any log error?

Did you run an occ files:scan -vvv?

In the user administration settings, are those groups to that user?


#4

Our server is running 9.0.2. The user does not have any files or folders. When running the files:scan -vvv with the userID I get 3 folders (root, /files and /cache).
The user is assigned to the group correctly. Just does not see the shared folder. Like visible in the screenshots: The user does see the folder when the permission is added directly for the user.

Did not look into the logs yet... but will do it now.


#5

Now I also ran files:cleanup. Did not help...
The owncloud.log is huge....
https://cloud.ec-group.org/index.php/s/uiVxup4zXDBINAx

There are some entries inside the apache error.log. :confused:
https://cloud.ec-group.org/index.php/s/EotCKZv8wXjEtpq


#6

The problem was solved by removing and readding the share permission for the group.


#7

I think the ownCloud 9.0.2 version you're running is highly outdated. Maybe you can consider to use a recent one to avoid such situations in the future?