Sharing is not allowed on external HD

I am using owncloud for my own NAS using a raspberry pi 4 connected to a external HD. All works well, however, I cannot create any shared link inside the mounted folder and its contents, I get the message “Sharing is not allowed”, as shown in the attached screenshot. If anybody knows why this is happening or what should I do to be able to share folders inside the external HD I would be very grateful.

Other details:
- ownCloud 10.11.0 (stable)
- In order to be able to mount an external HD, I had to include this line in config.php:
‘files_external_allow_create_new_local’ => ‘true’,

I just found the solution. While other people solved it, they did not explain well how to in the forum. So I include here the solution in a more clear way in case this helps other users. As shown in the fig attached below, one has to enable sharing the external hd which by default is unfortunately not enabled. This is done by clicking the settings (top right) option, and then in the Admin panel (left) select Storage. There, click the Settings wheel and finally tick “Enable sharing”.

I sure this is intentional and IMHO fully OK. Mounting an external volume doesn’t mean I want to share stuff on it.

Sure! I hope this helps other users who encounter the same issue. This threat should be closed since it has been solved.