Showing index.php content file instead loading owncloud

I think this screenshot shows enough. Well, the problem there is it doesn’t actually load an HTML file (the owncloud dashboard) but it shows the content of the PHP file.

Seems to be desame as . But I have it on a raspberry pi which doesnt fix with that.

1 Like

This is also not an ownCloud problem.
As you have already correctly found out mod_php is not enabled on your RPi.
Now you just need to enable the correct one, that is installed on your system.
Probably something like libapache2-mod-php7.3, you could run dpkg -l | grep php | grep mod.

With apachectl -M you can figure out the modules loaded into your apache.
Please paste the output of both commands.

1 Like