Slow upoad speeds from desktop client

desktop
client
9.1.x
help

#1

Problem: When uploading from the web client, I can achieve close to 600+ Mbps uploading a single large file (50GB). However, when I sync from the desktop, using only one folder and the same file, the upload speed averages somewhere closer to 20 Mbps. This is orders of magnitude slower. Not sure if there are optimizations I'm missing.

Steps to reproduce
1. Upload single large file (over 2GB+ should work) over web client.
2. Delete and remove file from account.
2. Upload same file via desktop client.

Expected behaviour
Upload speeds for web interface and desktop client should be somewhat comparable.

Actual behaviour
Upload speeds from desktop client are a significant fraction of the upload speeds over web client.

Client configuration
Client version: 2.3.0
Client operating system: Windows 10

Server configuration
Operating system: Ubuntu 16.04
Web server: apache2
Database: mysql Ver 14.14 Distrib 5.7.17
PHP version: PHP 7.0.15-0ubuntu0.16.04.4
ownCloud version (see ownCloud admin page): 9.1.3
Updated from an older ownCloud or fresh install: fresh install
Special configurations (external storage, external authentication, reverse proxy, server-side-encryption): owncloud storage is on an SMB connected network share,

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

{"reqId":"pXHFFg2mmN+mDar1VGIk","remoteAddr":"X.X.X.X","app":"PHP","message":"touch(): Utime failed: Operation not permitted at \/var\/www\/owncloud\/lib\/private\/Files\/Storage\/Local.php#187","level":3,"time":"2017-03-08T20:36:39+00:00","method":"PUT","url":"\/remote.php\/webdav\/A0303KUTV_EXTRA_34-35_UncompressedMOV.mov-chunking-1744387119-10465-517","user":"test-av-archives-user"}
{"reqId":"pXHFFg2mmN+mDar1VGIk","remoteAddr":"X.X.X.X","app":"PHP","message":"chmod(): Operation not permitted at \/var\/www\/owncloud\/lib\/private\/Log\/Owncloud.php#114","level":3,"time":"2017-03-08T20:36:39+00:00","method":"PUT","url":"\/remote.php\/webdav\/A0303KUTV_EXTRA_34-35_UncompressedMOV.mov-chunking-1744387119-10465-517","user":"test-av-archives-user"}

The log file errors only seem distantly related, but they are the only ones at least somewhat related, so I thought I'd include them for completeness sake.


#2

We're trying to improve performance with every release, but sometimes it might not be good :frowning:


#3

The 2.4 client will dynamically scale up the size of upload chunks. This should help.